Mailinglist Archive: opensuse-bugs (9716 mails)

< Previous Next >
[Bug 332750] HP scanner only works as root
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 2 Nov 2007 00:56:09 -0600 (MDT)
  • Message-id: <20071102065609.506D124526A@xxxxxxxxxxxxxxxxxxxxxx>

--- Comment #21 from Jarl Friis <jarl@xxxxxxxxxx> 2007-11-02 00:56:08 MST ---
(In reply to comment #15 from Johannes Meixner)
Can both of you activate the "set -x" line in
and then run it as root as
/usr/lib/YaST2/bin/test_and_set_scanner_access_permissions 2>/tmp/out
and attach /tmp/out text/plain attachments to this bug.

I did this as well...

However after doing so, the scanner (OfficeJet G85) is now available to
non-root. So I cannot reproduce this bug anymore.

To be honest, I don't know exactly what fixed my problem, but it seems like
running /usr/lib/YaST2/bin/test_and_set_scanner_access_permissions fixed the
problem. It could also be that that the security patch + reboot (i.e. restart
hplip) solved the problem. Even though I claimed in comment #12 that the
security patch (alone) did not fix the problem. I may be wrong here.

If you are still interested in the output of the command let me know, but I
don't think it is that interesting anymore since my system works now...

Configure bugmail:
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >