Mailinglist Archive: opensuse-bugs (15876 mails)

< Previous Next >
[Bug 301699] Partitions of one (of two) hdd not shown
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 30 Aug 2007 06:37:11 -0600 (MDT)
  • Message-id: <20070830123711.18181CC789@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=301699#c13





--- Comment #13 from Johannes Nohl <Johannes.Nohl@xxxxxxxxx>  2007-08-30 06:37:10 MST ---
Don't think so. I installed 10.3 Beta2 to a regognized partition (/dev/sdb2).
I'm now running 10.3.

Still: /proc/partitions is not showing partitions of /dev/sda (sda1-sda6).

parted shows:
#> parted /dev/sda
GNU Parted 1.8.7
Verwende /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) p                                                                
Model: ATA Maxtor 6Y120L0 (scsi)
Disk /dev/sda: 123GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags                    
 1      32,3kB  10,2GB  10,2GB  primary   fat32        , , , , , , lba, , ,
type=0c, , 
 2      10,2GB  37,0GB  26,8GB  extended               , , , , , , lba, , ,
type=0f, , 
 5      10,2GB  31,7GB  21,5GB  logical   fat32        , , , , , , , , ,
type=0b, ,    
 6      31,7GB  37,0GB  5371MB  logical   fat32        , , , , , , , , ,
type=0b, ,    
 3      37,0GB  38,1GB  1078MB  primary                , , , , , , , , ,
type=82, ,    
 4      38,1GB  123GB   84,8GB  primary   fat32        , , , , , , , , ,
type=0b, ,    

(parted) 

I thinks parted is NOT using /proc/partitions, hence the standard kernel
methods.Since I have to run it as root I think it's accessing disk directly. 

In my opinion the kernel module pata_amd is buggy! 10.2 used ide-generic not
pata nad it worked (both the installer and the installed system). Then the
IDE-hdd is shown as /dev/hda. And it works. 

If I do - in my running 10.3 Beta2:

 modprobe -r pata_amd
 modprobe ide-generic

My /proc/partitions look like this (as inside 10.2):

major minor  #blocks  name

   8    16  244198584 sdb
   8    17   52428568 sdb1
   8    18   86909760 sdb2
   8    19  104857196 sdb3
   3     0  120060864 hda
   3     1    9952236 hda1
   3     2          1 hda2
   3     3    1052257 hda3
   3     4   82831140 hda4
   3     5   20972826 hda5
   3     6    5245191 hda6

But: I can't imagine that I'm the only one with this disk error. Am I the only
one using a nForce4 chipset??


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References