Mailinglist Archive: opensuse-bugs (15870 mails)

< Previous Next >
[Bug 304123] New: Problem: Requirememt bar cannot be fulfilled.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 23 Aug 2007 19:46:02 -0600 (MDT)
  • Message-id: <bug-304123-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=304123

           Summary: Problem: Requirememt bar cannot be fulfilled.
           Product: openSUSE 10.3
           Version: Beta 2
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: P5 - None
         Component: libzypp
        AssignedTo: jkupec@xxxxxxxxxx
        ReportedBy: crrodriguez@xxxxxxxxxx
         QAContact: kkaempf@xxxxxxxxxx
          Found By: Development


#zypper install bar


1 Problems:
Problem: Requirememt bar cannot be fulfilled.

Problem: Requirememt bar cannot be fulfilled.
 There are no installable providers of bar

number, (r)etry or (c)ancel> 

huh ? o_O

First of all Typo : it says  "Requirememt"

second : geez!!, who created those error messages to be exposed to users ??
they are horrendous .. do you expect users to understand what a "installable
"provider"" is ? if you need them , what about a flag
--with-obscure-awful-errors in the command line ? :-)  

third: big wtf.. number, (r)etry or (c)ancel>  huh o_O ? if a package is not
there what is the sense of that dialog.. that's weird. ;)

shouldnt that say 

zypper install bar
..(repo refresh stuff)
package bar not found, suggestions : foobar barfoo barbarfoo
(return failure exit code)

in general, for user exposed errors do not use "provider", "resolvable" or
whatever zypp specific wording, our users dont understand that !! "package" ,
"pattern", "repository" are better choices.


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >