Mailinglist Archive: opensuse-bugs (15856 mails)

< Previous Next >
[Bug 302107] sax2: sets all Compose-Key variants on 2nd run
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 22 Aug 2007 06:35:29 -0600 (MDT)
  • Message-id: <20070822123529.72546245350@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=302107#c3


Jörg Hermsdorf <funtasyspace@xxxxxxxxx> changed:

           What    |Removed                                         |Added
----------------------------------------------------------------------------
             Status|RESOLVED                                        |REOPENED
         Resolution|WORKSFORME                                      |




--- Comment #3 from Jörg Hermsdorf <funtasyspace@xxxxxxxxx>  2007-08-22 06:35:28 MST ---
Ok, I just found out, that this happens only, if I configure my keyboard from a
running KDE session via YaST2 -> Hardware -> "Tastaturbelegung auswählen". In
that case sax writes the line 

Option       "XkbOptions" "Compose,compose:rctrl"

to xorg.conf.

But if I configure my keyboard while I'm in runlevel 3 via 'sax2 -r -m 0=fglrx'
then sax writes only 

Option       "XkbOptions" "compose:rctrl"

to xorg.conf.

Regarding the XkbModel oddity, I can say one thing for sure now:
If I do a fresh sax configuration (with no previously existing xorg.conf), sax
somehow decides that the 'Microsoft Natural Keyboard Pro / Microsoft Internet
Keyboard Pro' layout type should be used on my ThinkPad T60p. I should note,
that if I expand the drop-down selection box, the default selected 'Microsoft
Natural Keyboard Pro / Microsoft Internet Keyboard Pro' entry is the first one
in that list, followed by all the other layouts sorted in alphabetic order
starting with 'A'. I can scroll down to the layouts staring with 'M', where I
find a second entry with the same name 'Microsoft Natural Keyboard Pro /
Microsoft Internet Keyboard Pro'. 
OK, if I don't select a different layout type, leave the first one in the list
as the selected one and finish the configuration, sax won't write a XkbModel
Option to xorg.conf. If I run sax again, the selected layout type is again the
first entry in the selection list, but it's now the 'A4Tech KB-21' layout. The
'Microsoft Natural Keyboard Pro / Microsoft Internet Keyboard Pro' entry which
was there at position one during the first run, isn't there any longer. If I
finish the configuration now, sax writes the line 

Option       "XkbModel" "a4techKB21"

to xorg.conf. 

Next I did another fresh sax configuration, but this time I did not left the
first 'Microsoft Natural...' layout type as the selected one, but I scrolled
down to where all the layouts staring with 'M' are and selected it there. If I
finish the configuration this way, sax writes the XkbModel option during the
first run to xorg.conf. If I restart sax afterwards, this layout is correctly
shown as the selected one.


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >
References