Mailinglist Archive: opensuse-bugs (15829 mails)

< Previous Next >
[Bug 301704] New: libzypp update: libzypp.so.209()(64bit) is needed by ( installed) yast2-ncurses-2.14.4-3.x86_64
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 19 Aug 2007 09:30:59 -0600 (MDT)
  • Message-id: <bug-301704-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=301704

           Summary: libzypp update: libzypp.so.209()(64bit) is needed by
                    (installed) yast2-ncurses-2.14.4-3.x86_64
           Product: openSUSE 10.2
           Version: Final
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: P5 - None
         Component: Maintenance
        AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
        ReportedBy: suse-beta@xxxxxxxxx
         QAContact: qa@xxxxxxx
          Found By: ---


Created an attachment (id=158350)
 --> (https://bugzilla.novell.com/attachment.cgi?id=158350)
zypper log (bz2-compressed)

It seems the latest libzypp update causes some dependency problems with some
yast2-* packages.

# zypper in -y -t patch libzypp
Restoring system sources...
Parsing metadata for update-10.2...
Parsing metadata for inst-source...
Parsing metadata for non-oss...
Parsing metadata for home-cboltz...
Parsing RPM database...
Summary:
<install>   [S1:0][patch]libzypp-4029-0.noarch
<install>   [S1:0][atom]yast2-perl-bindings-2.14.0-10.x86_64
<install>   [S1:0][atom]yast2-pkg-bindings-2.14.4-6.x86_64
<install>   [S1:0][atom]zypper-0.6.15-0.2.x86_64
<install>   [S1:0][atom]libzypp-2.15.10-0.1.x86_64
<install>   [S1:0][atom]yast2-ncurses-2.14.4-4.x86_64
<uninstall> [S0:0][atom]libzypp-2.14.2-1.1.x86_64
<install>   [S1:0][package]libzypp-2.15.10-0.1.x86_64
<install>   [S1:0][package]yast2-ncurses-2.14.4-4.x86_64
<install>   [S1:0][package]yast2-perl-bindings-2.14.0-10.x86_64
<install>   [S1:0][package]yast2-pkg-bindings-2.14.4-6.x86_64
<install>   [S1:0][package]zypper-0.6.15-0.2.x86_64
<uninstall> [S0:0][package]yast2-perl-bindings-2.14.0-9.x86_64
<uninstall> [S0:0][package]yast2-ncurses-2.14.4-3.x86_64
<uninstall> [S0:0][package]yast2-pkg-bindings-2.14.4-5.x86_64
<uninstall> [S0:0][package]libzypp-2.14.2-1.1.x86_64
<uninstall> [S0:0][patch]libzypp-2533-0.noarch
<uninstall> [S0:0][package]zypper-0.6.15-0.1.x86_64
Continue? [y/n] y
Downloading: [S1:0][package]libzypp-2.15.10-0.1.x86_64, 2.3 M(7.4 M unpacked)
Downloading delta:
/rpm/x86_64/libzypp-2.14.2_2.15.10-1.1_0.1.x86_64.delta.rpm, 926.8 K
Applying delta:
/var/adm/mount/AP_0x00000004/rpm/x86_64/libzypp-2.14.2_2.15.10-1.1_0.1.x86_64.delta.rpm
Installing: [S1:0][package]libzypp-2.15.10-0.1.x86_64
[S1:0][package]libzypp-2.15.10-0.1.x86_64 Subprocess failed. Error: RPM failed:
error: Failed dependencies:
        libzypp.so.209()(64bit) is needed by (installed)
yast2-ncurses-2.14.4-3.x86_64
        libzypp.so.209()(64bit) is needed by (installed)
yast2-perl-bindings-2.14.0-9.x86_64
        libzypp.so.209()(64bit) is needed by (installed)
yast2-pkg-bindings-2.14.4-5.x86_64
        libzypp.so.209()(64bit) is needed by (installed)
zypper-0.6.15-0.1.x86_64


Invalid object
Invalid object
Installing: [S1:0][package]libzypp-2.15.10-0.1.x86_64
Downloading: [S1:0][package]yast2-ncurses-2.14.4-4.x86_64, 568.4 K(1.5 M
unpacked)
Downloading delta: ./rpm/x86_64/yast2-ncurses-2.14.4-3_4.x86_64.delta.rpm, 57.0
K
Applying delta:
/var/adm/mount/AP_0x00000004/rpm/x86_64/yast2-ncurses-2.14.4-3_4.x86_64.delta.rpm
Installing: [S1:0][package]yast2-ncurses-2.14.4-4.x86_64
Downloading: [S1:0][package]yast2-perl-bindings-2.14.0-10.x86_64, 124.8 K(364.1
K unpacked)
Downloading delta:
/rpm/x86_64/yast2-perl-bindings-2.14.0-9_10.x86_64.delta.rpm, 17.6 K
Applying delta:
/var/adm/mount/AP_0x00000004/rpm/x86_64/yast2-perl-bindings-2.14.0-9_10.x86_64.delta.rpm
Installing: [S1:0][package]yast2-perl-bindings-2.14.0-10.x86_64
Downloading: [S1:0][package]yast2-pkg-bindings-2.14.4-6.x86_64, 450.3 K(1.7 M
unpacked)
Downloading delta: ./rpm/x86_64/yast2-pkg-bindings-2.14.4-5_6.x86_64.delta.rpm,
56.0 K
Applying delta:
/var/adm/mount/AP_0x00000004/rpm/x86_64/yast2-pkg-bindings-2.14.4-5_6.x86_64.delta.rpm
Installing: [S1:0][package]yast2-pkg-bindings-2.14.4-6.x86_64
Downloading: [S1:0][package]zypper-0.6.15-0.2.x86_64, 212.5 K(573.1 K unpacked)
Downloading delta: ./rpm/x86_64/zypper-0.6.15-0.1_0.2.x86_64.delta.rpm, 20.9 K
Applying delta:
/var/adm/mount/AP_0x00000004/rpm/x86_64/zypper-0.6.15-0.1_0.2.x86_64.delta.rpm
Installing: [S1:0][package]zypper-0.6.15-0.2.x86_64
WARNING: One of installed patches affects the package manager itself, thus it
requires restart before executing next operations.


It seems the problem isn't critical - both zypper and yast are still working.

The zypper logfile is attached to this bugreport.


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups