Mailinglist Archive: opensuse-bugs (15829 mails)

< Previous Next >
[Bug 301703] New: SaX do not recognizes 3D Support with nVidia8600GT & Intel P35 Chipset
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 19 Aug 2007 08:22:08 -0600 (MDT)
  • Message-id: <bug-301703-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=301703

           Summary: SaX do not recognizes 3D Support with nVidia8600GT &
                    Intel P35 Chipset
           Product: openSUSE 10.2
           Version: Final
          Platform: i686
        OS/Version: openSUSE 10.2
            Status: NEW
          Severity: Normal
          Priority: P5 - None
         Component: SaX2
        AssignedTo: ms@xxxxxxxxxx
        ReportedBy: andreil1@xxxxxxxxxxx
         QAContact: qa@xxxxxxx
          Found By: Other


Created an attachment (id=158349)
 --> (https://bugzilla.novell.com/attachment.cgi?id=158349)
sax log files (with various options applied)

Hi,


I have new PC with Intel Core2 Duo, Gigabyte m/b,  
Intel P35 Chipset, 2GB RAM, and Asus 8600GT/512MB PCIe video card.

Software: SuSE 10.2 with latest kernel update (kernel-default-2.6.18.8-0.5),
latest nvidia driver 100.10.14 from its web site installed manually ("modprobe
nvidia" works).

nVidia driver and OpenGL drivers are OK for sure becuase I am was able to
configure X.org on another PC (moved that hard drive) with nVidia 6600 Card.

Symptom: neither "sax2" neither  "sax2 -r -m 0=nvidia" do not work as  
expected - sax2 switch to framebuffer mode.

I have replaced video card with MSI 8600GT, installed it into another  
PCIe slot, problem still exists. Upgrade to X.org 7.3 and sax2 to newer version
yelds the same result. Moreover, "sax2 -p" always resulted in X.org crash with
message "no screens found"

lspci:
01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0402 (rev 
a1)
03:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI 
Controller (rev 02)

sax2 -p (seems like problem with detection)
SaX: root Chip: 0 is -> VESA Framebuffer Graphics 01:00:0 0x10de 0x0402 AGP
fbdev

*************************************************

After upgrading kernel to third-party kernel-default-2.6.22.2-ccj52 I've got
some progress. sax2 was able to laucnh its own x server, but fail to recognize
3D support and proper screen resolution of Viewsonic VX2025 20" LCD monitor
(1680x1050).

After manual tweaking of xorg.conf everything seem to went fine, even 3D
support worked as expected.

17:09 linux-srv:~ > glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,

---

sax2 log files are attached.


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >