Mailinglist Archive: opensuse-bugs (15765 mails)

< Previous Next >
[Bug 287046] hal-luks-setup script is broken; mounting encrypted disk doesn 't work
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 11 Aug 2007 17:20:46 -0600 (MDT)
  • Message-id: <20070811232046.854C2CC789@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=287046#c9


Danny Kukawka <dkukawka@xxxxxxxxxx> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |NEEDINFO
      Info Provider|                            |wstephenson@xxxxxxxxxx




--- Comment #9 from Danny Kukawka <dkukawka@xxxxxxxxxx>  2007-08-11 17:20:44 MST ---
(In reply to comment #6 from Will Stephenson)
> Looks like something fell off the Precipice:
> 
> #1: the semantics of hal-is-caller-locked-out (I have no idea what it means)
> were apparently normalized, so it returns 0 when not locked, therefore the if
> ["$?" != "1" ] is inverted and always thinks it's locked

No, hal-is-caller-locked-out return 0 if it's not locked and therefor the check
is correct since every other value than 0 mean it's locked. 

The hal-is-caller-locked-out is needed to detect if the caller is allowed to
use the methode. Mean: if the user is allowed via PolicyKit to access the HAL
methode _and_ if the user is in a active session (via ConsoleKit) it returns 0
if not 1. This all looks correct to me. 

It doesn't work for you because of bug #298943.

> #2: Fix that and we see that the script is called with the required variable 
> HAL_PROP_STORAGE_ORIGINATING_DEVICE unset. 

What do you mean exactly? I could not find any usage of
HAL_PROP_STORAGE_ORIGINATING_DEVICE in the scripts. Only
HAL_PROP_BLOCK_STORAGE_DEVICE and this variable is set correctly.


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >