Mailinglist Archive: opensuse-bugs (15774 mails)

< Previous Next >
[Bug 298322] "zypper install xyz" doesn't install newer version of xyz.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 9 Aug 2007 02:19:52 -0600 (MDT)
  • Message-id: <20070809081952.4399B245350@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=298322#c7


Stefan Schubert <schubi@xxxxxxxxxx> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEEDINFO                    |ASSIGNED
      Info Provider|schubi@xxxxxxxxxx           |




--- Comment #7 from Stefan Schubert <schubi@xxxxxxxxxx>  2007-08-09 02:19:51 MST ---
If there is already an installed package you can set the requirement to
"amarok > 1.4.6-13". If the requirement failed you can show the
user
"The newest version of xyz is already installed". Otherwise the newest/best
package will be selected by the solver.
I have never tested, but it should work;-)

One problem: splitted/renamed packages will not be regarded here. Neither in 
libzypp nor in zypper. But that is a still open issue.

P.S.: Will, thank you for reopen. It has been the right way.


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References