Mailinglist Archive: opensuse-bugs (15732 mails)

< Previous Next >
[Bug 297703] Muting Master channel doesn't mute sound
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 6 Aug 2007 09:36:38 -0600 (MDT)
  • Message-id: <20070806153638.3DFFACC789@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=297703#c4


Péter Kerékfy <kerekfyp@xxxxxxxx> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEEDINFO                    |NEW
      Info Provider|kerekfyp@xxxxxxxx           |




--- Comment #4 from Péter Kerékfy <kerekfyp@xxxxxxxx>  2007-08-06 09:36:37 MST ---
(In reply to comment #3 from Takashi Iwai)
> Do you mean "mute" as the "Master Playback Switch" mixer element (i.e. mute the
> master volume, not set it to 0) ?

I mean _mute_ the master volume.

> 
> Anyway, please get the file /proc/asound/card0/codec#* file (for AD1981 one)
> for each state to check, e.g. master volume = 0, 50, 100%.   And master on
> /off.
> Attach these files together with the generated file via "alsactl -f somefile
> store" at each state.
> 

I have found out that the master mute switch behaves differently if there are 
external speakers or headphones connected to the laptop. In that case the
master mute switch actually mutes the headphones. (And of course the internal
speakers are also muted since the headphone is plugged in.)

I have stored the contents of the mentioned files in 8 different states of the
master volume control both with and without headphones. The file names are self
descriptive. Hope it helps. :-)


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >
References