Mailinglist Archive: opensuse-bugs (15702 mails)

< Previous Next >
[Bug 297650] New: Eric4 - Dependencies ?
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 5 Aug 2007 19:05:19 -0600 (MDT)
  • Message-id: <bug-297650-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=297650

           Summary: Eric4 - Dependencies ?
           Product: openSUSE 10.3
           Version: Alpha 7
          Platform: Other
        OS/Version: openSUSE 10.3
            Status: NEW
          Severity: Normal
          Priority: P5 - None
         Component: Development
        AssignedTo: pth@xxxxxxxxxx
        ReportedBy: nospamm@xxxxxx
         QAContact: qa@xxxxxxx
          Found By: Other


Since Alpha7 eric4 replaces eric3 in factory. After installation via Yast2 (All
dependencies checked) eric4 starts with the followin error:

test@linux-o599:~> eric4
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/eric4/eric4.py", line 20, in <module>
    from PyQt4.QtCore import QTextCodec, SIGNAL, SLOT, qWarning, \
TypeError: invalid argument to sipBadCatcherResult()
test@linux-o599:~>

eric3 installed from official tar.gz starts without a fault, and without manual
installing additional prerequisites.
My first guess is a forgotten change of dependencies from eric3 to eric4 rpm,
but as I am new to python I am not sure if it could also be a bug in eric4 or
PyQt4.

Peter Buschbacher.


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >