Mailinglist Archive: opensuse-bugs (15837 mails)

< Previous Next >
[Bug 296279] New: YaST and KPPP Should Agree On Required Groups and Permissions
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 31 Jul 2007 20:01:58 -0600 (MDT)
  • Message-id: <bug-296279-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=296279

           Summary: YaST and KPPP Should Agree On Required Groups and
                    Permissions
           Product: openSUSE 10.2
           Version: Final
          Platform: PC
        OS/Version: openSUSE 10.2
            Status: NEW
          Severity: Normal
          Priority: P5 - None
         Component: Network
        AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
        ReportedBy: crispin@xxxxxxxxxx
         QAContact: qa@xxxxxxx
          Found By: ---


I just tried to install and configure a WAN card (cellular wireless internet).
YaST installed & configured the card, and (I think) added me to the group
"dialout".

I then had to get & install KPPP to turn the PPP connection on and off. KPPP
wants me to be in the group uucp to be able to access the modem device. It
would be nice if YaST and KPPP would agree on the groups needed to access the
network.

Another permission problem is that KPPP won't start pppd unless it is suid
root. We need better privilege brokering so that non-privileged users can start
the network, or at least KPPP asks for the root password to be able to start
the network. Just running kppp from a root prompt doesn't work, as it does a
lot of KDE heavy lifting for the root account and then can't find the card,
because it was configured in the user account.


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >