Mailinglist Archive: opensuse-bugs (8111 mails)

< Previous Next >
[Bug 249809] New: memory leak in sysp will kill y2base in second stage
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 28 Feb 2007 09:08:36 -0700 (MST)
  • Message-id: <bug-249809-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=249809

Summary: memory leak in sysp will kill y2base in second stage
Product: openSUSE 10.3
Version: Alpha 1plus
Platform: PowerPC
OS/Version: Linux
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Installation
AssignedTo: yast2-maintainers@xxxxxxx
ReportedBy: olh@xxxxxxxxxx
QAContact: jsrain@xxxxxxxxxx
CC: power-bugs@xxxxxxxxxxxxxxxxxxxxxx


10.3a1+ on mango.suse.de

this ibook has 160mb.
once yast gets to the hardware configuration screen, sysp is started. it
consumes all memory. The kernel kills y2base (and other processes) because it
runs out of memory.

This top snapshot was taken while yast was killed. The sysp process kept
running until the network was shut down. Shortly before that, it consumed more
than 120MB of memory.

top - 16:59:38 up 50 min, 1 user, load average: 1.67, 0.47, 0.28
Tasks: 52 total, 4 running, 48 sleeping, 0 stopped, 0 zombie
Cpu(s): 63.4%us, 5.0%sy, 0.0%ni, 0.0%id, 30.7%wa, 1.0%hi, 0.0%si, 0.0%st
Mem: 157152k total, 155324k used, 1828k free, 44k buffers
Swap: 136544k total, 136544k used, 0k free, 4388k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
6272 root 18 0 93840 82m 528 R 64.5 54.1 0:14.41 sysp
3775 root 18 0 238m 48m 2852 S 0.0 31.4 7:26.19 y2base
6231 root 20 0 24764 4840 836 S 0.0 3.1 0:01.01 init.pl
5717 root 18 0 8956 2304 400 S 0.0 1.5 0:01.30 ag_uid
3706 root 15 0 25544 1740 688 S 0.0 1.1 0:13.16 Xorg
3050 haldaemo 15 0 7112 1144 712 S 0.0 0.7 0:03.69 hald
3714 root 15 0 10052 880 632 S 0.0 0.6 0:00.81 fvwm2
4673 root 15 0 14284 852 664 S 0.0 0.5 0:00.09 NetworkManager
4380 root 15 0 12180 676 540 S 0.0 0.4 0:00.65 sshd
4433 root 15 0 2836 656 488 R 2.0 0.4 0:16.13 top
4672 root 15 0 3912 564 560 S 0.0 0.4 0:00.03 NetworkManagerD
4671 root 15 0 2956 544 440 R 0.0 0.3 0:00.03 dhcdbd
3051 root 25 0 3524 432 428 S 0.0 0.3 0:00.07 hald-runner
4338 root 25 0 4440 432 400 S 0.0 0.3 0:00.19 ag_initscripts
4416 root 16 0 5052 416 416 S 0.0 0.3 0:00.42 bash
1890 root 25 0 4440 412 408 S 0.0 0.3 0:00.77 YaST2.Second-St
3172 root 25 0 4572 412 408 S 0.0 0.3 0:00.49 YaST2.call
4094 root 20 0 4440 400 400 S 0.0 0.3 0:00.07 ag_xauth

10.2 installed ok
10.3a1 installed ok, module the hwinfo --framebuffer bug that prevented sax
from working.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >
Follow Ups