Mailinglist Archive: opensuse-bugs (7967 mails)

< Previous Next >
[Bug 216853] Getting ACPI errors on harddrive when booting up
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 25 Feb 2007 07:45:19 -0700 (MST)
  • Message-id: <20070225144519.50E8925C887@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=216853





------- Comment #40 from teheo@xxxxxxxxxx 2007-02-25 07:45 MST -------
Hello, sorry about late response. I was on the road.

I'm confused because the error message you reported for 2.6.19.2 is NOT a
detection problem. It's HSM violation and timeouts for DMA READ command which
is probably issued by partition code.

Prior to 800b399669ad495ad4361d134df87401ae36f44f, polling identify is used if
and only if ATA_FLAG_DETECT_POLLING flag is set. After the commit, it's the
default behavior for all drivers. ata_piix had the flag set before the commit,
so the commit does not introduce any behavior change for ata_piix.

To summarize...

1. commit 800b399669ad495ad4361d134df87401ae36f44f only changes device
detection and should NOT break or fix HSM violation during DMA READ.

2. commit 800b399669ad495ad4361d134df87401ae36f44f does NOT introduce behavior
change for ata_piix.

Please...

1. Post the dmesg of opensuse 10.2 without any patch.

2. Post the dmesg of opensuse 10.2 with the patch generated from 800b...

3. Post the patch itself.

I think we're confused about something. Let's clear it up. Thanks.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >