Mailinglist Archive: opensuse-bugs (8048 mails)

< Previous Next >
[Bug 243032] possible /opt/gnome -> /usr upgrade problems with ld.so.conf
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 15 Feb 2007 04:33:26 -0700 (MST)
  • Message-id: <20070215113326.464ACFCD@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=243032





------- Comment #11 from sbrabec@xxxxxxxxxx 2007-02-15 04:33 MST -------
Possible work-around in glibc:

%post
# This script is required for <=openSUSE10.2 and <=SLES10 upgrade protection.
# Are we upgrading from < 10.3?
if test -f etc/profile.d/gnome-filesystem.sh ; then
echo /opt/gnome/lib >etc/ld.so.conf.d/glibc-temp.conf
cat >sbin/conf.d/SuSEconfig.glibc-temp <<EOF
#! /bin/sh
rm -f \$r/etc/ld.so.conf.d/glibc-temp.conf
\$r/sbin/conf.d/SuSEconfig.glibc-temp
EOF
fi

NOTE: This script needs bi-arch stuff to work properly.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >
References