Mailinglist Archive: opensuse-bugs (8113 mails)

< Previous Next >
[Bug 244584] New: blam should not depend on gtk-sharp-1.x
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 12 Feb 2007 06:35:06 -0700 (MST)
  • Message-id: <bug-244584-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=244584

Summary: blam should not depend on gtk-sharp-1.x
Product: openSUSE 10.3
Version: Alpha 0plus
Platform: All
OS/Version: All
Status: NEW
Severity: Enhancement
Priority: P5 - None
Component: GNOME
AssignedTo: bnc-team-gnome@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: andreas.hanke@xxxxxxxxxxxxxx
QAContact: qa@xxxxxxx
OtherBugsDependingO 244537
nThis:


gtk-sharp-1.x is a legacy package. blam still depends on it, but it shouldn't.

To solve the problem, I have the following proposals:

(1) Do nothing, keep blam and gtk-sharp-1.x.

(2) Drop blam. The version we currently have (1.8.2) is 1 1/2 years old and the
original author (Imendio) doesn't maintain it any longer.

(3) Keep the version we have (1.8.2) and patch it to use gtk-sharp-2.x. The
changes are trivial and this works, Debian shipped it this way for a while.

(4) Switch to the "forked" version 1.8.4 by Carlos Martín Nieto. He is the
Debian package maintainer and also the new upstream maintainer and this version
includes all SUSE patches except for blam-desktop.patch (I've sent them
upstream a while ago).

If you care what other major distributions are doing: Mandriva uses 1.8.4,
Fedora uses 1.8.2 with a trivial patch to use gtk-sharp2 and gecko-sharp2.
Please let me know which option you prefer.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >