Mailinglist Archive: opensuse-bugs (8113 mails)

< Previous Next >
[Bug 244546] New: libvisual-plugins-0.4.0-43 : array subscript is above array bounds
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 12 Feb 2007 01:49:04 -0700 (MST)
  • Message-id: <bug-244546-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=244546

Summary: libvisual-plugins-0.4.0-43 : array subscript is above
array bounds
Product: openSUSE 10.3
Version: unspecified
Platform: All
OS/Version: SuSE Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: dcb314@xxxxxxxxxxx
QAContact: qa@xxxxxxx


I just tried to compile package libvisual-plugins-0.4.0-43
with the GNU C compiler version 4.3 snapshot 20070209.

The compiler said

draw.c:69: warning: array subscript is above array bounds

The source code is

i=0;
while (priv->life[i] > 0)

but

float life[FUSEE_MAX];

Suggest code rework. Maybe

i=0;
while ((i < FUSEE_MAX) && (priv->life[i] > 0))


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >