Mailinglist Archive: opensuse-bugs (8113 mails)

< Previous Next >
[Bug 244537] New: drop gtk-sharp-1.x from the distribution
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 12 Feb 2007 00:45:18 -0700 (MST)
  • Message-id: <bug-244537-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=244537

Summary: drop gtk-sharp-1.x from the distribution
Product: openSUSE 10.3
Version: Alpha 0plus
Platform: All
OS/Version: All
Status: NEW
Severity: Enhancement
Priority: P5 - None
Component: GNOME
AssignedTo: bnc-team-gnome@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: andreas.hanke@xxxxxxxxxxxxxx
QAContact: qa@xxxxxxx


gtk-sharp-1.x is unmaintained software. It's time to get rid of it, most other
distributions did this already.

Some time ago I asked for the list of affected packages, this was the result:

CASA (cmashayekhi@xxxxxxxxxx)
CASA_auth_token_client (jluciani@xxxxxxxxxx)
CASA_auth_token_server (jluciani@xxxxxxxxxx)
autopano-sift (sbrabec@xxxxxxx)
banshee (gnome-maintainers@xxxxxxx)
beagle (gnome-maintainers@xxxxxxx)
beagle-index (gnome-maintainers@xxxxxxx)
blam (gnome-maintainers@xxxxxxx)
collect-desktop-files (coolo@xxxxxxx)
compdir (btimothy@xxxxxxxxxx)
gecko-sharp (mono-maintainers@xxxxxxx)
gtksourceview-sharp2 (mono-maintainers@xxxxxxx)
helix-banshee (gnome-maintainers@xxxxxxx)
libbtctl (gnome-maintainers@xxxxxxx)
monodevelop (mono-maintainers@xxxxxxx)
tomboy (gnome-maintainers@xxxxxxx)



CASA: Is already fixed, uses gtk-sharp-2.x now.

autopano-sift: No idea, this is not present in factory. Maybe an internal
package?

banshee, helix-banshee: Dependency must be bogus, as banshee does definitely
not use gtk-sharp-1.x any more. Probably a packaging bug.

beagle: Dito.

blam: The package in factory does indeed still depend on gtk-sharp-1.x. Can be
fixed by dropping blam (Imendio does _not_ maintain it any more) or by
upgrading to the forked version from http://www.cmartin.tk/blam.html

collect-desktop-files: Dependency can be removed if gtk-sharp-1.x is dropped.

compdir: Not present in factory => Internal?

gecko-sharp: Superseded by gecko-sharp2, only blam needs it. Should be handled
together with blam.

gtksourceview-sharp2: Dependency looks bogus to me.

libbtctl: Only the unmaintained mono bindings in libbtctl-sharp need
gtk-sharp-1.x. Will never be fixed because nobody uses them (not touched in
CVS/SVN since 2 1/2 years), mono support can be dropped.

monodevelop: Dependency doesn't look correct to me.

tomboy: Dependency was wrong and has been fixed recently.

I'm reporting this in the GNOME component because most affected packages happen
to be GNOME packages. Feel free to reassign.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >