Mailinglist Archive: opensuse-bugs (8107 mails)

< Previous Next >
[Bug 243582] New: Packages do not build on SLE10
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 8 Feb 2007 08:38:02 -0700 (MST)
  • Message-id: <bug-243582-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=243582

Summary: Packages do not build on SLE10
Product: openSUSE 10.3
Version: unspecified
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Sound
AssignedTo: tiwai@xxxxxxxxxx
ReportedBy: pzb@xxxxxxxxxx
QAContact: qa@xxxxxxx


I tried to backport the alsa* and pulseaudio packages from Factory to SLE10,
and ran into a couple of small issues:

alsa-utilities in alsa claims to need GETTEXT 0.15. Simply changing
configure.in to require 0.14 seems to work fine. Is there a solid need for
0.15 or could we include a patch to only require 0.14?

alsa-plugins.spec has %internal set to 1, even in the openSUSE Factory version.
This makes it impossible to build in the openSUSE Build System. Could this be
macro'd to autodetect if the internal packages are available, rather than
hardcoded?

pulseaudio.spec needs to BuildRequire flac-devel at least on SLE10.

Are these fixes that could be integrated into the packages in STABLE?


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >