Mailinglist Archive: opensuse-bugs (8080 mails)

< Previous Next >
[Bug 211511] suspend to RAM hangs on resume on Dell, regression between 2.6.16.21-0.21 and -0.25
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 6 Feb 2007 19:22:32 -0700 (MST)
  • Message-id: <20070207022232.1AC6E25C887@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=211511





------- Comment #28 from jimc@xxxxxxxxxxxxx 2007-02-06 19:22 MST -------
Yes, not a single driver module was loaded at the time, and there were supposed
to have been no drivers compiled into the kernel either except non-modular ones
such as the serio driver.
I dug around in the sources, and came to the conclusion that on an Intel
chipset the devices are powered off and on using an ACPI BIOS call. It turns
out that there is a new BIOS (A09) for my machine, but the list of affected
issues was totally irrelevant, things like a setup item for more disc acoustic
choices. Nonetheless I flashed my BIOS... and suspend-to-RAM started working!
25 successive suspend events were done with no errors, on 2 different days.
Corrupt BIOS? Error in ACPI, not on the BIOS issues list but fixed
nonetheless? We'll probably never know what the problem was :-( Nor whether it
will fail again in the future :-( By the way, the testing was done with all
drivers active including ATI's fglrx version 8.25.18 (3D accelerated graphics
for Radeon X300).
Pavel, I'm not sure of the etiquette of setting the bug status, so would
you please close it? Thank you for all your help, and for your contributions
to the software and disc suspend code.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >