Mailinglist Archive: opensuse-bugs (8048 mails)

< Previous Next >
[Bug 242237] New: add-plugins.sh shell script error
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 5 Feb 2007 10:00:38 -0700 (MST)
  • Message-id: <bug-242237-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=242237

Summary: add-plugins.sh shell script error
Product: SUSE Linux 10.1
Version: Final
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Firefox
AssignedTo: bnc-team-mozilla@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: vogt@xxxxxxxxxxxxxxxxxx
QAContact: qa@xxxxxxx


Hello,

I think I found a bug in

/usr/lib/seamonkey/add-plugins.sh
/usr/lib/thunderbird/add-plugins.sh


In line 36 there is this:

# check for .dic file
if ! [ -r $MYSPELL/${lang}[-_]${country}.dic ] ; then
continue
fi

shouldn't it be:
# check for .dic file
if [ ! -r $MYSPELL/${lang}[-_]${country}.dic ] ; then
continue
fi

The error looks like this:

/add-plugins.sh: line 36: [: /usr/share/myspell/en_US.dic: binary operator
expected
/add-plugins.sh: line 36: [: /usr/share/myspell/en_US.dic: binary operator
expected
-> added myspell dictionaries

Very likely a bug.
Can it be fixed?



regards,

Martin


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >
Follow Ups