Mailinglist Archive: opensuse-bugs (7967 mails)

< Previous Next >
[Bug 242048] New: diald-1.0-400: array subscript is above array bounds
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 4 Feb 2007 14:42:57 -0700 (MST)
  • Message-id: <bug-242048-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=242048

Summary: diald-1.0-400: array subscript is above array bounds
Product: openSUSE 10.3
Version: unspecified
Platform: All
OS/Version: SuSE Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: dcb314@xxxxxxxxxxx
QAContact: qa@xxxxxxx


I just tried to compile package diald-1.0-400
with the GNU C compiler version 4.3 snapshot 20070202.

The compiler said

utils.c:16: warning: array subscript is above array bounds

The source code is

if (len == 128) dt[len] = 0;

but

static char dt[128];

Clearly broken code. Suggest code rework.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >