Mailinglist Archive: opensuse-bugs (7967 mails)

< Previous Next >
[Bug 242037] New: Firefox doesn't start when dbus is running
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 4 Feb 2007 08:57:32 -0700 (MST)
  • Message-id: <bug-242037-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=242037

Summary: Firefox doesn't start when dbus is running
Product: openSUSE 10.2
Version: Final
Platform: i686
OS/Version: Linux
Status: NEW
Severity: Blocker
Priority: P5 - None
Component: Firefox
AssignedTo: bnc-team-mozilla@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: erik@xxxxxxxxxxx
QAContact: qa@xxxxxxx


When the dbus system daemon is running, firefox refuses to start up. The
firefox-bin process will just sit there and wait. No message is given to the
user.

Presumably this is because firefox can't get the network status and assumes no
network is connected. This is wrong in two ways: first of all the network is
connected fine and working, and firefox should always start, regardless of
network status.

When I use network-manager, firefox will eventually start up. Of course the
network has been active for a long time then (say, 15 minutes at least).
However, network-manager doesn't work correctly either and is useless on my
system anyway, so I just use ifup.

In summary: firefox should just always start. Maybe I want to develop a website
on my laptop with locally running apache, maybe I just want to open files on
the local file system. Anyway, firefox should never ever check my network
connection. Even when firefox thinks my network is down, it should start and
warn the user using some friendly dialog; never ever let a process block
without emiting any clue to the user as to why!

I marked this bug as a blocker, because firefox doesn't work at all.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >
Follow Ups