Mailinglist Archive: opensuse-bugs (8080 mails)

< Previous Next >
[Bug 230213] Everytime I insert my PCMCIA card, the device number is increased by one
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 2 Feb 2007 14:00:32 -0700 (MST)
  • Message-id: <20070202210032.8B24425C889@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=230213





------- Comment #28 from dieter.jurzitza@xxxxxxxxxxx 2007-02-02 14:00 MST -------
Hi Mr. Zoz,
yesterday I couldn't test. Today was better. I added several debug-printouts to
your script in order to make the processing more transparent.
The result you can see from the attached files called "netifacelog.zozdebug",
two subsequent boots, one renaming forward, one renaming back.
The ra61 (with binary firmware image) driver is always getting into the script
with a single name only; in contrast, the ra0 driver (not needing the binary
image) comes into the script with two names.
In the case for the ra61 your script makes the error because (in the first
place) it renames ra0 (what should be ra0 according to
30-net_persistent_names.rules) to ra2, renaming it back to ra0 with the next
boot. Obviously there is a timing impact here, because the script
rename_netiface is called with two names for the same interface at two
subsequent boots.
Maybe you can track things down from here on, I am stuck :-)
I attached the script from you I modified with regard to debugging, too, so you
can use it for yourself (if you want to).
Let me know if there is anything else I could do to track this down.
Take care


Dieter Jurzitza


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >