Mailinglist Archive: opensuse-bugs (8080 mails)

< Previous Next >
[Bug 197929] acroread: line 493: [: -ge: unary operator expected
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 1 Feb 2007 07:42:12 -0700 (MST)
  • Message-id: <20070201144212.0D08AFC1@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=197929





------- Comment #30 from Ulrich.Windl@xxxxxxxxxxxxxxxxxxxx 2007-02-01 07:42 MST -------
In reply to comment #28: I just meant to provide a better method than
"prefixing a zero" to handle undefined numeric variables. When comparing
numbers, both operands have to be numbers unfortunately, or you would just
replace a syntax error with a runtime error. Fixing the exact problem in a
minimal invasive way is definitely OK, but having an eye on other potential
problems is OK as well.
if [ -z "$version" ]; then
echo "Houston, we have a problem (with determining the GTK version)" 1>&2
fi


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >