Mailinglist Archive: opensuse-bugs (8080 mails)

< Previous Next >
[Bug 239089] Get rid of /usr/X11R6/
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 1 Feb 2007 05:44:48 -0700 (MST)
  • Message-id: <20070201124448.9E29925C887@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=239089





------- Comment #16 from anicka@xxxxxxxxxx 2007-02-01 05:44 MST -------
Stefan: I have read the code and I concluded that it really should work as I
wrote before. Both ssh and sshd call its local xauth (it did not make much
sense to me to do otherwise, anyway). So I tested a bit more...

First of all: /usr/X11R6/bin/xauth is not hardcoded anymore in 10.2 and newer,
/usr/bin/xauth is used instead - so no need to set XAuthLocation. (In manpages
is still written that /usr/X11R6/bin/xauth, this is a bug which will be fixed.)

Login from 10.2 to 10.1 works for me even if compatibility link removed (I just
tried to login, checked for warnings and ran xterm). Login from 10.1 to 10.2
works for me also.

When I tried to move xauth to another location and set XAuthLocation according
to it, then it really did not work. It looks that DISPLAY is not set correctly
when XAuthLocation is read from the config file, I have no clue why yet - it
looks like a bug that should be fixed. I will take a look what is wrong.

But as far as I was able to test, we do not need /usr/X11R6/bin/xauth link for
openssh when compile-time default location used, the only thing that does not
work is setting XAuthLocation in the config file.

If you have some counter example, please let me know - I am not able to produce
any.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >