Mailinglist Archive: opensuse-bugs (8956 mails)

< Previous Next >
[Bug 216071] New: yelp can't find DTD or is very slow
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 28 Oct 2006 07:39:20 -0600 (MDT)
  • Message-id: <bug-216071-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=216071

Summary: yelp can't find DTD or is very slow
Product: SUSE Linux 10.1
Version: Final
Platform: x86-64
OS/Version: SuSE Linux 10.1
Status: NEW
Severity: Major
Priority: P5 - None
Component: GNOME
AssignedTo: bnc-team-gnome@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: dg001@xxxxxxxxxxx
QAContact: qa@xxxxxxx


Recently the website http:www.oasis-open.org was not accessible due to planned
maintenance, when I tried to use yelp in Gnome. Yelp reported that the XML
helpfile was not well-formed XML.
For example I run yelp from the command-line:
yelp /opt/gnome/share/gnome/help/gnumeric/C/gnumeric.xml

I wondered why yelp tries to load the DTDs from the Internet and disabled the
network adapter connecting to the Internet. Running yelp again immediatley
showed the correct help page.

An strace shows that yelp looks for DTD in
/opt/kde3/share/apps/ksgmltools2/customization/dtd/docbookx.dtd
/usr/share/xml/docbook/schema/dtd/4.4/docbookx.dtd
when there is no Internet connection. The second path is the correct one.

When there is an Internet connection yelp only looks for the DTD on the
Internet and when oasis-open is online this is very slow.

It would be better if the behavior of yelp is configurable or yelp looks in the
local path first for retrieving the DTD. This would improve performance and
avoid errors, when oasis-open is down.

Detlef


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >
Follow Ups