Mailinglist Archive: opensuse-bugs (8956 mails)

< Previous Next >
[Bug 215445] skipping unreachable packages does not work
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 26 Oct 2006 19:25:00 -0600 (MDT)
  • Message-id: <20061027012500.C80C7B8F@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=215445





------- Comment #2 from andreas.hanke@xxxxxxxxxxxxxx 2006-10-26 19:25 MST -------
Indeed, it doesn't work. Tested with:

yast2-packager-2.13.157-2
yast2-pkg-bindings-2.13.100-4

Bug 181658 claims to have this fixed in yast2-pkg-bindings-2.13.100 and
yast2-packager-2.13.155, but it's obviously not true.

I simulated a broken repository, and this is the result - exactly the same as
before the fix:

2006-10-27 03:08:27 <5> linux-lebr(21194) [base] Exception.cc(log):94
PackageProvider.cc(providePackage):91 RETHROW:
SourceProvideFile.cc(provideFile):135: File
/usr/src/packages/RPMS/i586/C-1-1.i586.rpm fails integrity check. Expected:
[sha1-ca840e86b95bee699e38928e28a20761389b97e2] Got:
[sha1-da39a3ee5e6b4b0d3255bfef95601890afd80709]
2006-10-27 03:08:27 <3> linux-lebr(21194) [wfm] Package.cc(PkgCommit):2153
Pkg::Commit has failed: ZYpp::commit has failed
2006-10-27 03:08:27 <3> linux-lebr(21194) [YCP] PackageInstallation.ycp:154 Bad
media number 0

It stops at that point and omits all the dependent packages.

I _really_ hope that this is not a feature, because it will break installations
as it did with 10.1.

(And no, I did not click "abort", not even "maybe")


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >
References