Mailinglist Archive: opensuse-bugs (8956 mails)

< Previous Next >
[Bug 214239] New: yum: distroverpkg should be openSUSE-release, not suse-release
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 21 Oct 2006 04:24:39 -0600 (MDT)
  • Message-id: <bug-214239-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=214239

Summary: yum: distroverpkg should be openSUSE-release, not suse-
release
Product: openSUSE 10.2
Version: Alpha 5 plus
Platform: All
OS/Version: All
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: andreas.hanke@xxxxxxxxxxxxxx
QAContact: qa@xxxxxxx


yum has the following line in /etc/yum.conf by default:

distroverpkg=suse-release

This works because it looks up the rpmdb for all packages that provide the
value of distroverpkg if no package with exactly that name is installed, and
takes the first one it can find.

But this is very fragile, it would not work in the case where multiple packages
provide suse-release.

It should be:

distroverpkg=openSUSE-release


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >