Mailinglist Archive: opensuse-autoinstall (41 mails)

< Previous Next >
Re: [opensuse-autoinstall] opensuse 11.4 pxe installation - no repository in 'iso:/?iso=openSUSE-11.4-DVD-i586.iso&url=nfs://...
Le 2011-05-24 09:50, Joschi Brauchle a écrit :

I did have similar problems...

Check the way you pass the URL, the problem lies somewhere in the "iso:/" part: I experiemented with "iso://" and "iso:///" and did get it working with one of them as far as I remember.

Alternatively: The problem is the combination of mounting an iso image thru nfs. Try extracting your iso file on the nfs server into a directory and then use a plain "nfs://<server>/<directory/" repository. That works for sure!

I won't retype all I said in the past on the subject since it's all in the bugzilla and I tried installs with ISO and with repo. It didn't work when the NFS server was a solaris 10 machine, but it worked when it was an opensuse machine.

On 05/24/2011 03:44 PM, Pierre Girard wrote:
Le 2011-05-09 09:31, Guenther Haas a écrit :

Think I have the same o a similar problem (again) with our old nfs
My installation of 11.4 also stops because of an NFS timeout during
the repository.


Last I heard, seems to be a bug in zypp.

I worked around the problem by installing an http server and doing
installs that way instead of using NFS.

On 03/14/2011 08:24 PM, Pierre Girard wrote:
I'm trying to install opensuse 11.4 and so far the machine loads pxe,
starts initrd and linux, and starts the installation process. At some
point it looks to add repositories and I get an error message saying
there was a problem adding a repository.

Here's the message from y2log:

2011-03-14 10:56:08 <1> [YCP]
Progress.ycp:599 Subprogress initialization skipped
2011-03-14 10:56:08 <3> [YCP]
Packages.ycp:1484 No repository in

2011-03-14 10:56:08 <1> [Pkg]
Packages.ycp:1063 Pkg Builtin called: LastError

I checked the path, and I was able to manually mount the directory
from one of the terminals without problem.

Have you tried to manually mount the repository from the (interrupted)
installation system? Does this work?

If not, does

mount -o nolock,nfsvers=2 <repo> <dir>

work? You can also try nfsvers=3. For me this works, but not without the
"unlock" option as the rpcstatd is missing at this time and can not be

My problem now is, that from a pxe boot I see no possibility to pass the
nolock option to linuxrc. The existing option nfsops=... doesn't allow
the use of nolock, only udp, tcp, vers or rsize & wsize.

Maybe those problems are not connected, but they sound similar to me.
My colleague has no problems installing via NFS from a server with
newer nfs version.

Any ideas?


To unsubscribe, e-mail: opensuse-autoinstall+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-autoinstall+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups