Mailinglist Archive: opensuse-autoinstall (140 mails)

< Previous Next >
Re: [suse-autoinstall] sles 8 RAID in autoyast
  • From: Nate Faerber <nfaerber@xxxxxxxxxxxxxxxxxxxx>
  • Date: Mon, 2 Jun 2003 18:48:47 +0000 (UTC)
  • Message-id: <1054579518.7369.15.camel@xxxxxxxxxxxxxxxxxxxxxxxx>
Anas,

Thanks. I guess I am having problems installing this update. I am
using an NFS directory to do my install over the network. I have tried
untarring the y2update.tar.bz2 in the nfs directory, and I have tried
updating the boot/root file using the update script. Is there an
argument I need to give to the installer so it will look for the update?

I am starting the nfs install with this line in my PXE config:
LABEL raidinstall
KERNEL linux-sles8
APPEND initrd=initrd-sles8 ramdisk_size=65536 insmod=bcm5700
netdevice=eth1 install=nfs://192.168.50.1/nfs-install/sles8/
autoyast=nfs://192.168.50.1/custom/raidinstall.xml

The y2update.tar.bz2 file was extracted to the sles8/ directory, but I
got the same errors while trying to do my raid install.

Is my autoyast file correct? What am I missing?

-nate

On Sat, 2003-05-31 at 09:18, Anas Nashif wrote:
> Hi,
> This is issue is fixed in the y2update image (and now a tar also), which
> can be found at www.suse.de/~nashif/autoinstall/y2update.
>
> All these changes will be available as official fixed in the next
> Service Pack.
>
> If any issues remain, let me know.
> Anas
>
> Nate Faerber wrote:
> > Hi,
> >
> > I am having a lot of trouble getting autoyast to install a raid
> > configuration. I have tried several methods from the "documentation"
> > and mailing-lists but I still get errors regarding the size of '/' and
> > '/var' (basically, the raid arrays are not being set up properly).
> >
> > This is SLES 8 on an Opteron system. I have even tried installing
> > manually then using yast2 to create a clone.xml. Using the clone.xml
> > untouched on the same system results in a "Preparting the RAID system
> > failed" error.
> >
> > Here is the partitioning and raid portion of my control file:
> >
> > <partitioning config:type="list">
> > <drive>
> > <device>/dev/hda</device>
> > <partitions config:type="list">
> > <partition>
> > <format config:type="boolean">true</format>
> > <mount>/boot</mount>
> > <partition_id config:type="integer">131</partition_id>
> > <partition_nr config:type="integer">1</partition_nr>
> > <size>80mb</size>
> > </partition>
> > <partition>
> > <format config:type="boolean">false</format>
> > <mount />
> > <partition_id config:type="integer">253</partition_id>
> > <partition_nr config:type="integer">2</partition_nr>
> > <raid_name>/dev/md1</raid_name>
> > <size>2040mb</size>
> > </partition>
> > <partition>
> > <format config:type="boolean">false</format>
> > <mount />
> > <partition_id config:type="integer">253</partition_id>
> > <partition_nr config:type="integer">3</partition_nr>
> > <raid_name>/dev/md2</raid_name>
> > <size>6000mb</size>
> > </partition>
> > <partition>
> > <format config:type="boolean">false</format>
> > <mount />
> > <partition_id config:type="integer">253</partition_id>
> > <partition_nr config:type="integer">5</partition_nr>
> > <raid_name>/dev/md3</raid_name>
> > <size>1020mb</size>
> > </partition>
> > <partition>
> > <format config:type="boolean">false</format>
> > <mount />
> > <partition_id config:type="integer">253</partition_id>
> > <partition_nr config:type="integer">6</partition_nr>
> > <raid_name>/dev/md4</raid_name>
> > <size>10gb</size>
> > </partition>
> > </partitions>
> > <use>all</use>
> > </drive>
> > <drive>
> > <device>/dev/hdb</device>
> > <partitions config:type="list">
> > <partition>
> > <format config:type="boolean">true</format>
> > <mount>/bootmirror</mount>
> > <partition_id config:type="integer">131</partition_id>
> > <partition_nr config:type="integer">1</partition_nr>
> > <size>80mb</size>
> > </partition>
> > <partition>
> > <format config:type="boolean">false</format>
> > <mount />
> > <partition_id config:type="integer">253</partition_id>
> > <partition_nr config:type="integer">2</partition_nr>
> > <raid_name>/dev/md1</raid_name>
> > <size>2040mb</size>
> > </partition>
> > <partition>
> > <format config:type="boolean">false</format>
> > <mount />
> > <partition_id config:type="integer">253</partition_id>
> > <partition_nr config:type="integer">3</partition_nr>
> > <raid_name>/dev/md2</raid_name>
> > <size>6000mb</size>
> > </partition>
> > <partition>
> > <format config:type="boolean">false</format>
> > <mount />
> > <partition_id config:type="integer">253</partition_id>
> > <partition_nr config:type="integer">5</partition_nr>
> > <raid_name>/dev/md3</raid_name>
> > <size>1020mb</size>
> > </partition>
> > <partition>
> > <format config:type="boolean">false</format>
> > <mount />
> > <partition_id config:type="integer">253</partition_id>
> > <partition_nr config:type="integer">6</partition_nr>
> > <raid_name>/dev/md4</raid_name>
> > <size>10gb</size>
> > </partition>
> > </partitions>
> > <use>all</use>
> > </drive>
> > </partitioning>
> > <raid config:type="list">
> > <raid_device>
> > <device_name>/dev/md1</device_name>
> > <parity_algorithm>left-asymmetric</parity_algorithm>
> > <persistent_superblock
> > config:type="boolean">true</persistent_superblock>
> > <raid_level>1</raid_level>
> > <chunk_size>64</chunk_size>
> > <mount>swap</mount>
> > <format config:type="boolean">true</format>
> > <filesystem config:type="symbol">swap</filesystem>
> > </raid_device>
> > <raid_device>
> > <device_name>/dev/md2</device_name>
> > <parity_algorithm>left-asymmetric</parity_algorithm>
> > <persistent_superblock
> > config:type="boolean">true</persistent_superblock>
> > <raid_level>1</raid_level>
> > <chunk_size>64</chunk_size>
> > <mount>/</mount>
> > <format config:type="boolean">true</format>
> > <filesystem config:type="symbol">ext3</filesystem>
> > </raid_device>
> > <raid_device>
> > <device_name>/dev/md3</device_name>
> > <parity_algorithm>left-asymmetric</parity_algorithm>
> > <persistent_superblock
> > config:type="boolean">true</persistent_superblock>
> > <raid_level>1</raid_level>
> > <chunk_size>64</chunk_size>
> > <mount>/var</mount>
> > <format config:type="boolean">true</format>
> > <filesystem config:type="symbol">ext3</filesystem>
> > </raid_device>
> > <raid_device>
> > <device_name>/dev/md4</device_name>
> > <parity_algorithm>left-asymmetric</parity_algorithm>
> > <persistent_superblock
> > config:type="boolean">true</persistent_superblock>
> > <raid_level>1</raid_level>
> > <chunk_size>64</chunk_size>
> > <mount>/home</mount>
> > <format config:type="boolean">true</format>
> > <filesystem config:type="symbol">ext3</filesystem>
> > </raid_device>
> > </raid>
> >
> > thanks
> > -nate
> >
> >
>


< Previous Next >
Follow Ups