Mailinglist Archive: opensuse-autoinstall (79 mails)

< Previous Next >
Re: [suse-autoinstall] grub or lilo boot loader?
  • From: Anas Nashif <nashif@xxxxxxx>
  • Date: Fri, 8 Nov 2002 00:47:24 +0000 (UTC)
  • Message-id: <20021108004654.GB22510@xxxxxxx>
* Bernd Leibing <bernd.leibing@xxxxxxxxxxxxx> [Nov 07. 2002 21:34]:
> Hi all,
>
> suse 8.1 by default installs the grub bootloader. right?
>
> Autoinstallation from a SuSE-8.1 repository, which was copied from a
> (german) SuSE-8.1 DVD also installs the grub bootloader for me.
>
> But when I switch to a repository which is based on the SuSE-8.1 FTP
> Distribution the same autoinst.xml configuration results in lilo getting
> installed.

Ok, LILO being installed on a new system is not something bad, it can
happen in different cases, i.e. Root on RAID/LVM or if grub can't be
used.
But in this case, it's a bug that was introduced after the release of
8.1 and now it's in the FTP dist. The latest update package fixes this.
>
> Interestingly an "interactive" installation from the same SuSE-8.1 FTP
> still installs grub !?!
>
> I tried without a bootloader resource in
> the control file. Is there a bootloader resource to force the use
> of grub as bootloader?


Currently you cant choose, but we are working on improving the options
for the bootloader, i.e. password prtotection etc.


Anas
>
> --
> Bernd 'Bing' Leibing <bernd.leibing@xxxxxxxxxxxxx>
> Computing Center, University of Ulm, Germany
>
>
> --
> To unsubscribe, e-mail: suse-autoinstall-unsubscribe@xxxxxxxx
> For additional commands, e-mail: suse-autoinstall-help@xxxxxxxx
--
Anas Nashif <nashif@xxxxxxxx>, SuSE Linux AG
Montreal (Laval), Canada

< Previous Next >
Follow Ups
References