Mailinglist Archive: opensuse-autoinstall (79 mails)

< Previous Next >
Re: [suse-autoinstall] Can't find
  • From: "Aaron McSorley" <aaron.mcsorley@xxxxxxx>
  • Date: Thu, 21 Nov 2002 23:46:53 +0000 (UTC)
  • Message-id: <3DDD7063.1060507@xxxxxxx>
Here is my config which seems to work
note that all of the "info" options are on the same line as the kernel

I have another question, what is "framebuffer 1" doing, I assumed
it would enable framebuffer for a gui install, but that doesn't work on
my hardware. Is there something "framebuffer 1" is doing that "vga=788"
isn't ?

-----------------------------------------------

color white/blue black/light-gray
default 0
timeout 8
#framebuffer 1

title autoinstall-bootp
bootp
root (nd)
ifconfig --server=192.168.0.1

kernel (nd)/linux vga=788 language=english netdevice=eth0
server=192.168.0.1 serverdir=/home/ftp/pub/suse install=nfs://192.168.0.1/home/ftp/pub/suse autoyast=nfs://192.168.0.1/home/ftp/pub/suse/autoyast.xml

initrd (nd)/initrd


-------------------------------------------------


...aaron.mcsorley@xxxxxxx



Amanda Dahl,(4686) wrote:
Hello,
I've changed my menu.lst to the following and it still cannot find the Installation Source:

\--------BEGIN menu.lst----------

color white/blue black/light-gray
default 0
timeout 8
framebuffer 1

title autoinstall-bootp
bootp
ifconfig --server=192.168.122.160
root (nd)
kernel (nd)/linux install=nfs://192.168.122.160/tftpboot/suse80 server=192.168.122.160 serverdir=/tftpboot autoyast=default
initrd (nd)/initrd

-------------END menu.lst --------\

It finds:
- Both the initrd and linux, which are located in /tftpboot.

It can't seem to find:
-The autoinst.xml, which is located both in /tftpboot and on the floppy.
-The SuSE repository, which is located in /tftpboot/suse80.

My TFTP server is configured to use /tftpboot as the root dir.
The directory /tftpboot is exported, and the NFS server is running. I can mount it elsewhere.

Does anyone have any idea why it cannot find the Installation Source?

Many thanks,
Amanda






Anas Nashif wrote:

* Amanda Dahl,(4686) <amanda@xxxxxxxxxxxxxxxxxx> [Nov 15. 2002 16:08]:

Hello,
I am using the Grub floppy to initiate system boot via bootp & tftpd. It is able to locate and load the kernel, but when it gets to the SuSE Installation Program it tries to locate the infofile and then moves on to a screen where it says "Please make sure that CD number 1 is in your drive!". I have supplied a location for the installation source, but it doesn't seem to be finding it.
I am specifying the locations of everything in the menu.lst on the Grub disk, as my DHCP server setup must remain plain vanilla if possible. Here is what I have for the menu.lst:

color white/blue black/light-gray
default 0
timeout 8
framebuffer 1

title autoinstall-bootp
bootp
tftpserver 192.168.122.160

from the grub manual:
Caution: This command exists only for backward compatibility. Use ifconfig
(see ifconfig) instead.


root (nd)
kernel (nd)/linux install=(nd)/suse80 serverdir=(nd)/suse80 autoyast=(nd)/autoinst.xml

I am not sure whether this is possible. install needs a valid URI, i,e,
install=nfs://192.168.1.1/suse80
Same applies to autoyast.

Anas


initrd (nd)/initrd

Any ideas would be greatly appreciated.

Cheers,
Amanda



--
Amanda K. Dahl
Senior Systems Administrator
Biopendium Production
Inpharmatica, Ltd.
60 Charlotte Street
London, W1T 2NU
United Kingdom

020 7074 4686 tel
020 7074 4700 fax
amanda@xxxxxxxxxxxxxxxxxx
http://www.inpharmatica.co.uk



--
To unsubscribe, e-mail: suse-autoinstall-unsubscribe@xxxxxxxx
For additional commands, e-mail: suse-autoinstall-help@xxxxxxxx

--
Anas Nashif <nashif@xxxxxxxx>, SuSE Linux AG
Montreal (Laval), Canada



--
_______ Aaron McSorley
\____ | Advanced Processor Validation
/| | | Micro Texas Microprocessor Division
| |___| | Devices e-mail: aaron.mcsorley@xxxxxxx
|____/ \| Voice:512.602.0417
pgr:512.604.0946



< Previous Next >