Mailinglist Archive: opensuse-arm (77 mails)

< Previous Next >
[opensuse-arm] openSUSE-Tumbleweed-ARM-JeOS-raspberrypi3.aarch64-2017.01.13-Build4.1.raw booting from usb-hdd/thumb drive without SD-Card
Hello All,

let me first thank all those of you who made the above mentioned image possible. To me, it is the first image since at least October 2016 that ist booting on my rpi3 without any problems. The only thing not working is wifi. But that was to be expected (as it sports kernel 4.9), as Andreas Färber already said on this list.

So, Thank you and keep up the good work.

As most of you may already know it is possible to boot an rpi3 without SD-Card from usb (hdd or thumb drive) directly since August 2016, following the instructions given in the link below:

https://www.raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/msd.md

I tried that and it works without problems using Raspbian on both, an hdd and a thumb drive.

Since my rpi3 is now unlocked and able to boot from usb I tried to make it boot with openSUSE using the image in the subject and copying bootcode.bin und start.elf from here

https://github.com/raspberrypi/firmware/tree/next/boot

to /dev/sda1/efi on my usb-hdd and - alternatively - to my usb thumb drive, replacing the original files on it.

To make a long story short: It works! ...sort of (more about that later). It is possible to boot openSUSE-aarch64 on an rpi3 without SD-card directly from usb.

And now we come to the "sort of" part of the boot process.

- Grub2 appears and loads the kernel and initrd
- all kinds of boot messages appear about services that were started and targets that were reached.

But then the system hangs indefinitely with the following line:

"A start job is running for dev-sda2.device (xys/no limit)"

I spent the last two weeks trying to figure out what the problem is and how to solve it but did not find a solution.
Here is what I found out and tried so far:

1. The message originates from systemd-fstab-generator

a) To me it is not clear, though, why the system boots to this point and stops here. Since /boot on /dev/sda2 is found, services are started and targets reached, why is it a problem to find /dev/sda2.device?

b) It does not matter how partition names are given to sda2. No matter if the name is derived from uuid, id, block device, anything else, the boot process stops here.

2. I tried to circumvent systemd-fstab-generator by

a) adding fstab=0 or "no" to the kernel command line to prevent it from generating this line from my /dev/sda2 fstab entry. This is ignored by systemd-fstab-generator, the problem persists.

b) adding "x-systemd.device-timeout=10" to the /dev/sda2 line of fstab. This is ignored by systemd-fstab-generator, the problem persists.

c) renaming the file to systemd-fstab-generator.nil in /usr/lib/systemd/generators and creating an new initrd without it.
The system still hangs at the same point but without the start job message.

My questions are

- Why does the system hang with the above message and won't boot on?
- How can this problem be resolved?

Any kind of help is appreciated.

Best regards,

Freigeist
--
On a long enough timeline the survival rate for everyone drops to zero...
--
To unsubscribe, e-mail: opensuse-arm+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-arm+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups