Mailinglist Archive: opensuse-arm (170 mails)

< Previous Next >
Re: [opensuse-arm] raspberrypi image 2016.03.24-Build2.1 almost working [solved]
  • From: Herbert Graeber <herbert@xxxxxxxxxxxxxxx>
  • Date: Mon, 28 Mar 2016 13:17:05 +0200
  • Message-id: <1676866.0Yq6F2xBao@pollux.graeber.private>
Am Sonntag, 27. März 2016, 22:46:17 CEST schrieb Alexander Graf:
On 26.03.16 13:01, Herbert Graeber wrote:
Am Freitag, 25. März 2016, 22:57:48 CET schrieb Herbert Graeber:
Am Freitag, 25. März 2016, 21:13:17 CET schrieb Dirk Müller:
But the Problem is, that boot.script contains "rootflags=size=100%" and
"size=100%" isn't an allowed mount option for ext4. This option only
for tmpfs. I have found this option in and every
other of several *.kiwi files I looked into, too.

right, but there is a kiwi-hooks/ script on firstboot
in the image that should get executed

and remove those flags:
# On second boot, the rootfs is no longer tmpfs and dracut would

the # command line argument, remove it again from the config

for file in /etc/sysconfig/bootloader /etc/default/grub

do ⇥ [ -e "$file" ] && sed -i -e 's/rootflags=size=100%//' $file

Those lines are missing in /kiwi-hooks/ from openSUSE-

can you provide the kiwi boot log ? perhaps there is a hint why the
code isn't getting executed.

I can have a look tomorrow, but I think the missing lines are the cause
this an a log won't show more.

Today I tried the next image (2016.03.25-Build2.1). The problem remains.
I have attached /var/log/, /boot/boot.script and /kiwk-hooks/

What's strange is, that a raspberrypi2 image from the same date contains
the right kiwi-hooks/

I think I've tracked it down. The problem was that the rpi2 image is
built from exactly the openSUSE:Factory:ARM JeOS package, while the rpi1
downstream image gets built from the upstream JeOS-raspberrypi
description plus a few modifications.

Because of the way OBS works, binary files don't get stored as diffs in
a linked repository but instead get overwritten. The
script is part of a tgz file (uboot-setup-raspberrypi.tgz).

In between the last update to that tgz and today the rootflags line got
added to, but wasn't updated in the downstream copy of
the tgz. I've done that manually now. I hope in the not too distant
future we can just throw away all of this downstream RPi stuff and have
great, working upstream Linux based RPi images for 1, 2 and 3 ;).

I have tested 2016.03.25-Build2.3 and the second boot works.

Thanks a lot for digging into this,

One thought: My first mail was meant as a status report, but lead to some
sort of bug triaging. Shall I make a bug report next time?

< Previous Next >
Follow Ups