Mailinglist Archive: opensuse-arm (80 mails)

< Previous Next >
Re: [opensuse-arm] Install arm64 packages
  • From: Christoffer Dall <christoffer.dall@xxxxxxxxxx>
  • Date: Mon, 5 Aug 2013 16:13:48 -0700
  • Message-id: <20130805231348.GG16694@cbox>
On Mon, Aug 05, 2013 at 08:50:26AM +0200, Adrian Schröter wrote:
Am Samstag, 3. August 2013, 21:20:14 schrieb Christoffer Dall:
Hi all,

I downloaded the root tarball from here
(https://en.opensuse.org/Portal:ARM/AArch64) and have run the FS in
the foundation model, but it seems I don't have vim or gcc or other
build tools in that image.

I tried using zypper to install it, but it can't find a vim package,
it complains for vim-data telling me that nothing provides vim-base.

I looked for gcc and make or development packages using "zypper se"
but apparently I'm doing something wrong, because nothing shows up.

Can anyone tell me what I'm doing wrong?

Do you have any valid repositories registered?

zypper lr

The 12.3 repo can be added via

zypper ar \
http://download.opensuse.org/repositories/devel:/ARM:/AArch64:/12.3/standard/

12.3
zypper ref

thanks, worked for vim. Not quite sure how to get the needed package of
gcc/make (equivalent of debian build-essential) on this system though;

$ zypper in -t pattern devel

doesn't seem to provide me anything, but maybe I'm doing this wrong too.
Installing all required packages individually for now...


vim-base is available there at least. We should add this path by default
though ...

That or add the instructions to
https://en.opensuse.org/Portal:ARM/AArch64 so super noobs like myself
can figure things out :)

In any case, thanks for the pointer!

-Christoffer
--
To unsubscribe, e-mail: opensuse-arm+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-arm+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups