Mailinglist Archive: opensuse-amd64 (200 mails)

< Previous Next >
Tyan 2885 and 2.6.0-test11-mm1 "no init found" on boot.iso
  • From: "Steven A. DuChene" <linux-clusters@xxxxxxxxxxxxxx>
  • Date: Mon, 22 Dec 2003 19:23:42 +0000 (UTC)
  • Message-id: <20031222142355.R16138@xxxxxxxxxxxxxxxxxxxxx>
I am attempting to modify the SuSE9-AMD64 boot.iso so I can attempt to install SuSE9-X86_64
to a Tyan 2885 system with two SATA drives hung off of the Silicon Image 3114 controller.
The system has 2Gb of memory (two 512Kb sticks stuck in each processor memory bank).
I have the controller configured in IDE mode in the BIOS and I was able to build a 2.6
kernel (2.6.0-test11-mm1) that has the siimage driver in it that seems to recognize the
drives during boot up. The SATA drives show up as hde and hdg. The CD/DVD drive hung off
of the built in AMD8111 IDE controller shows up as hda. I have been unable to get this
kernel placed on an altered SuSE9 boot.iso install image without causing various boot

I have built the kernel with all of the appropriate drivers built into the kernel image
so I shouldn't require any modules. I built in the following drivers:

Processor family (Opteron/Athlon64/Hammer/K8)
Symmetric multi-processing support
Allocate 3rd-level pagetables from highmem
MTRR (Memory Type Range Register) support
PCI support
PCI access mode (Any)
Vector-based interrupt indexing
Legacy /proc/pci interface
PCI device name database
ISA support
Plug and Play support
Plug and Play BIOS support
Plug and Play BIOS /proc interface
Normal floppy disk support
Loopback device support
Broadcom Tigon3 support <<<<<<<<<< tg3
Silicon Image chipset support <<<<<<<<<< siimage
Initial RAM disk (initrd) support
Support for Large Block Devices
MISC (executable format)
Enable loadable module support
Automatic kernel module loading
RAM disk support
(65536) Default RAM disk size
AMD and nVidia IDE support (CD/DVD drive conntected to the onboard IDE controller)
IDE/ATA-2 DISK support
Enhanced IDE/MFM/RLL disk/cdrom/tape/floppy support
PCI IDE chipset support
Sharing PCI IDE interrupts support
Generic PCI IDE Chipset Support
Generic PCI bus-master DMA support
Use PCI DMA by default when available
Second extended fs support
Ext3 journalling file system support
ROM file system support
ISO 9660 CDROM file system support
Microsoft Joliet CDROM extensions
UDF file system support
DOS FAT fs support
MSDOS fs support
VFAT (Windows-95) fs support
/proc file system support
/dev/pts file system for Unix98 PTYs
Virtual memory file system support (former shm fs)
Compressed ROM file system support
NFS file system support
SCSI device support
legacy /proc/scsi/ support
SCSI disk support

Now I did build in other things like input device and USB support and etc. but the above
is a pretty complete list (I can supply my kernel config file if necessary). I did not
include any SCSI controller drivers or SCSI emulation support in the IDE section.
I also did not include Network block device support or Minix fs support. Since I did not
include Minix fs support I altered the initrd file to be gzipped ext2 instead of Minix.
(created a ext2 fs on a file and then tar'ed all the stuff over from the uncompressed and
loopback mounted Minix initrd file). Since I have what I hope to be a 2.6 kernel that
should not require any modules I removed all of the SuSE9-X86_64 2.4 kernel module files
from the initrd file that was on the original boot.iso

I have quite a bit of Linux experience (since 1993) and I am running other 2.6.0-test
kernel on my other x386 system but this is the first Opteron system I have goofed with.

During kernel bootup it does say

RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem) read only
Freeing unused kernel memory: 168k freed
Kernel panic: No init found. Try passing init= option to the kerme.

The mkisofs command I am using to build my test boot.iso images is:

mkisofs -b boot/loader/isolinux.bin -c boot/loader/ -no-emul-boot\
-boot-load-size 4 -boot-info-table -l -R -r -o boot_k26sminitrd.iso newboot/

I tried passing init=/linuxrc or init=linuxrc but I still get the "No init found"
I also tried a 2.4 kernel built which a friend in CZ built with a sata_sil
driver in it but that did not find the 3114 device. I did not have a "No init found"
problem with that kernel however.

Can anyone see from my above list of drivers I compiled into the kernel anything
obvious I would be missing? Or any other problems that might cause this?

BTW, I originally was working with the default 4Mb ramdisk_size as compiled into the
2.6 kernel but then I thought I might try bumping that up to 64Mb since that is
what is needed for the rescue image (I have been trying to boot to either that or
the standard install choice). Still same thing.

I tried also booting this kernel and initrd via PXE across the network but I had no
luck with that either. ARGH!!!
Steven A. DuChene linux-clusters@xxxxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages