Mailinglist Archive: libyui-commit (19 mails)

< Previous Next >
[libyui-commit] Build failed in Jenkins: libyui-ncurses-pkg-master #120
  • From: admin@xxxxxxxxxxxx
  • Date: Wed, 17 Apr 2019 16:37:19 +0000 (UTC)
  • Message-id: <1543004565.4.1555519039923.JavaMail.jenkins@ci-opensuse>
See <http://ci.opensuse.org/job/libyui-ncurses-pkg-master/120/display/redirect>

------------------------------------------
[...truncated 39.16 KB...]
[ 15s] [182/201] keeping libboost_headers-devel-1.69.0-1.1
[ 15s] [183/201] cumulate libboost_chrono1_69_0-devel-1.69.0-1.2
[ 15s] [184/201] cumulate libboost_program_options1_69_0-devel-1.69.0-1.2
[ 15s] [185/201] keeping libboost_test1_69_0-devel-1.69.0-1.2
[ 15s] [186/201] keeping sysuser-shadow-2.0-2.12
[ 15s] [187/201] cumulate libboost_date_time1_69_0-devel-1.69.0-1.2
[ 15s] [188/201] cumulate libboost_program_options-devel-1.69.0-1.1
[ 15s] [189/201] keeping libboost_test-devel-1.69.0-1.1
[ 15s] [190/201] keeping system-group-hardware-20170617-7.1
[ 15s] [191/201] cumulate libboost_thread1_69_0-devel-1.69.0-1.2
[ 15s] [192/201] cumulate libboost_thread-devel-1.69.0-1.1
[ 15s] [193/201] keeping libutempter0-1.1.6-10.9
[ 15s] [194/201] keeping libyui-devel-3.5.0-1.1
[ 15s] [195/201] cumulate libyui-ncurses-devel-2.50.4-2.5
[ 15s] [196/201] cumulate libzypp-devel-17.11.4-1.1
[ 15s] [197/201] keeping util-linux-2.33.1-2.1
[ 15s] [198/201] keeping aaa_base-84.87+git20190404.8684de3-1.1
[ 15s] [199/201] keeping rpm-build-4.14.2.1-4.1
[ 15s] [200/201] keeping aaa_base-malloccheck-84.87+git20190404.8684de3-1.1
[ 15s] [201/201] keeping post-build-checks-84.88+git20181015.ceb5c96-1.2
[ 15s] now installing cumulated packages
[ 15s] Preparing...
########################################
[ 15s] Updating / installing...
[ 15s] libgpg-error0-1.36-1.1
########################################
[ 16s] libassuan0-2.5.3-1.1
########################################
[ 16s] libyui9-3.4.2-2.2
########################################
[ 16s] libyui-ncurses9-2.50.4-2.5
########################################
[ 16s] popt-devel-1.16-31.1
########################################
[ 16s] rpm-devel-4.14.2.1-4.1
########################################
[ 17s] openssl-1_1-1.1.0h-4.6
########################################
[ 17s] libboost_thread1_69_0-1.69.0-1.2
########################################
[ 17s] libnettle6-3.4.1-1.2
########################################
[ 17s] libhogweed4-3.4.1-1.2
########################################
[ 17s] openssl-1.1.0h-1.2
########################################
[ 17s] libopenssl-1_1-devel-1.1.0h-4.6
########################################
[ 17s] libopenssl-devel-1.1.0h-1.2
########################################
[ 18s] libsolv-devel-0.7.4-1.1
########################################
[ 18s] libgcrypt20-1.8.4-2.3
########################################
[ 18s] libksba8-1.3.5-2.4
########################################
[ 18s] libtasn1-6-4.13-2.3
########################################
[ 18s] libtasn1-4.13-2.3
########################################
[ 19s] libcurl-devel-7.64.1-1.1
########################################
[ 19s] ncurses-devel-6.1-14.1
########################################
[ 19s] libxml2-tools-2.9.9-1.1
########################################
[ 19s]
libboost_program_options1_69_0-1.69.0-########################################
[ 19s]
libboost_program_options1_69_0-devel-1########################################
[ 19s]
libboost_program_options-devel-1.69.0-########################################
[ 19s] libboost_date_time1_69_0-1.69.0-1.2
########################################
[ 19s]
libboost_date_time1_69_0-devel-1.69.0-########################################
[ 19s] libboost_chrono1_69_0-1.69.0-1.2
########################################
[ 20s]
libboost_chrono1_69_0-devel-1.69.0-1.2########################################
[ 20s]
libboost_thread1_69_0-devel-1.69.0-1.2########################################
[ 20s] libboost_thread-devel-1.69.0-1.1
########################################
[ 20s] xz-devel-5.2.4-1.5
########################################
[ 20s] libxml2-devel-2.9.9-1.1
########################################
[ 20s] libusb-1_0-0-1.0.22-1.4
########################################
[ 20s] libudev-mini-devel-241-2.1
########################################
[ 20s] libp11-kit0-0.23.12-1.3
########################################
[ 20s] libgnutls30-3.6.7-1.1
########################################
[ 20s] libzstd1-1.3.8-1.2
########################################
[ 21s] libsolv-tools-0.7.4-1.1
########################################
[ 21s] libsqlite3-0-3.27.2-1.1
########################################
[ 21s] libnpth0-1.6-1.2
########################################
[ 22s] gpg2-2.2.15-1.1
########################################
[ 22s] libgpgme11-1.13.0-1.1
########################################
[ 22s] libzypp-17.11.4-1.1
########################################
[ 23s] libzypp-devel-17.11.4-1.1
########################################
[ 23s] libyui-ncurses-devel-2.50.4-2.5
########################################
[ 23s] removing nis flags from
/var/tmp/build-root/openSUSE_Factory-x86_64/etc/nsswitch.conf...
[ 23s] now finalizing build dir...
[ 24s] -----------------------------------------------------------------
[ 24s] I have the following modifications for libyui-ncurses-pkg.spec:
[ 24s] 21c21
[ 24s] < Release: 0
[ 24s] ---
[ 24s] > Release: 1
[ 24s] -----------------------------------------------------------------
[ 24s] ----- building libyui-ncurses-pkg.spec (user abuild)
[ 24s] -----------------------------------------------------------------
[ 24s] -----------------------------------------------------------------
[ 24s] + exec rpmbuild -ba --define '_srcdefattr (-,root,root)' --nosignature
/home/abuild/rpmbuild/SOURCES/libyui-ncurses-pkg.spec
[ 24s] setting SOURCE_DATE_EPOCH=1554984000
[ 24s] Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.YopK06
[ 24s] + umask 022
[ 24s] + cd /home/abuild/rpmbuild/BUILD
[ 24s] + cd /home/abuild/rpmbuild/BUILD
[ 24s] + rm -rf libyui-ncurses-pkg-2.49.0
[ 24s] + /usr/bin/bzip2 -dc
/home/abuild/rpmbuild/SOURCES/libyui-ncurses-pkg-2.49.0.tar.bz2
[ 24s] + /usr/bin/tar -xof -
[ 24s] + STATUS=0
[ 24s] + '[' 0 -ne 0 ']'
[ 24s] + cd libyui-ncurses-pkg-2.49.0
[ 24s] + /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
[ 24s] + exit 0
[ 24s] Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.phYzj1
[ 24s] + umask 022
[ 24s] + cd /home/abuild/rpmbuild/BUILD
[ 24s] + /usr/bin/rm -rf
/home/abuild/rpmbuild/BUILDROOT/libyui-ncurses-pkg-2.49.0-1.x86_64
[ 24s] ++ dirname
/home/abuild/rpmbuild/BUILDROOT/libyui-ncurses-pkg-2.49.0-1.x86_64
[ 24s] + /usr/bin/mkdir -p /home/abuild/rpmbuild/BUILDROOT
[ 24s] + /usr/bin/mkdir
/home/abuild/rpmbuild/BUILDROOT/libyui-ncurses-pkg-2.49.0-1.x86_64
[ 24s] + cd libyui-ncurses-pkg-2.49.0
[ 24s] + export 'CFLAGS=-O2 -Wall -D_FORTIFY_SOURCE=2
-fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables
-fstack-clash-protection -DNDEBUG'
[ 24s] + CFLAGS='-O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong
-funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -DNDEBUG'
[ 24s] + export 'CXXFLAGS=-O2 -Wall -D_FORTIFY_SOURCE=2
-fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables
-fstack-clash-protection -DNDEBUG'
[ 24s] + CXXFLAGS='-O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong
-funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -DNDEBUG'
[ 24s] + ./bootstrap.sh /usr
[ 24s] checking for /usr/share/libyui/buildtools/CMakeLists.common...
[ 24s] OK: linked to
/home/abuild/rpmbuild/BUILD/libyui-ncurses-pkg-2.49.0/./CMakeLists.txt.
[ 24s] + mkdir build
[ 24s] + cd build
[ 24s] + cmake .. -DYPREFIX=/usr -DDOC_DIR=/usr/share/doc/packages
-DLIB_DIR=lib64 -DCMAKE_BUILD_TYPE=RELEASE
[ 24s] CMake Deprecation Warning at CMakeLists.txt:6 (cmake_policy):
[ 24s] The OLD behavior for policy CMP0053 will be removed from a future
version
[ 24s] of CMake.
[ 24s]
[ 24s] The cmake-policies(7) manual explains that the OLD behaviors of all
[ 24s] policies are deprecated and that a policy should be set to OLD only
under
[ 24s] specific short-term circumstances. Projects should be ported to the
NEW
[ 24s] behavior and not rely on setting a policy to OLD.
[ 24s]
[ 24s]
[ 24s] CMake Deprecation Warning at CMakeLists.txt:12 (cmake_policy):
[ 24s] The OLD behavior for policy CMP0043 will be removed from a future
version
[ 24s] of CMake.
[ 24s]
[ 24s] The cmake-policies(7) manual explains that the OLD behaviors of all
[ 24s] policies are deprecated and that a policy should be set to OLD only
under
[ 24s] specific short-term circumstances. Projects should be ported to the
NEW
[ 24s] behavior and not rely on setting a policy to OLD.
[ 24s]
[ 24s]
[ 25s] -- The C compiler identification is GNU 8.3.1
[ 25s] -- The CXX compiler identification is GNU 8.3.1
[ 25s] -- Check for working C compiler: /usr/bin/cc
[ 25s] -- Check for working C compiler: /usr/bin/cc -- works
[ 25s] -- Detecting C compiler ABI info
[ 25s] -- Detecting C compiler ABI info - done
[ 25s] -- Detecting C compile features
[ 26s] -- Detecting C compile features - done
[ 26s] -- Check for working CXX compiler: /usr/bin/c++
[ 26s] -- Check for working CXX compiler: /usr/bin/c++ -- works
[ 26s] -- Detecting CXX compiler ABI info
[ 26s] -- Detecting CXX compiler ABI info - done
[ 27s] -- Detecting CXX compile features
[ 28s] -- Detecting CXX compile features - done
[ 28s] -- Found Curses6: /usr/lib64/libncursesw.so;/usr/lib64/libpanelw.so
[ 28s] -- ZYpp path not set. Looking for it.
[ 28s] -- ZYpp found: includes in /usr/include, library in
/usr/lib64/libzypp.so
[ 28s] -- Found Libyui: (Version: 3.5.0)
[ 28s] -- Found Libyui-ncurses: (Version: 2.50.4)
[ 28s] -- USE_C_STD not set, defaulting to gnu99
[ 28s] -- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
[ 28s] --
[ 28s] --
********************************************************************************
[ 28s] --
[ 28s] -- libyui-ncurses-pkg has been configured with following options:
[ 28s] --
[ 28s] -- Plugin-Name: ncurses-pkg
[ 28s] -- Extension-Name:
[ 28s] -- Library-Dependencies:
Curses6;Zypp;Libyui;Libyui-ncurses
[ 28s] -- Plugin is for use with:
[ 28s] -- targetlib to build: yui-ncurses-pkg
[ 28s] --
[ 28s] -- Version: 2.49.0
[ 28s] -- SO-Version: 10.0.0
[ 28s] --
[ 28s] -- Used Build-Option: RELEASE
[ 28s] -- Used Compiler-Flags: -O2 -Wall
-D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables
-fasynchronous-unwind-tables -fstack-clash-protection -DNDEBUG -std=c++0x
-fmessage-length=0 -Wall -Werror -O3
[ 28s] -- linking against:
[ 28s] -- using includes from:
/usr/include/yui/ncurses;/usr/include/yui/ncurses/..;/usr/include/yui;/usr/include/yui/..;/usr/include;/usr/include
[ 28s] --
[ 28s] --
[ 28s] -- Install to Prefix: /usr
[ 28s] -- use Shared-Dir: /usr/share
[ 28s] -- use Library-Dir: /usr/lib64/yui
[ 28s] -- use Include-Dir:
/usr/include/yui/ncurses-pkg
[ 28s] -- use CMake Plugin-InstallDir:
/usr/lib64/cmake/libyui-ncurses-pkg
[ 28s] -- use Doc-Dir:
/usr/share/doc/packages/libyui-ncurses-pkg10
[ 28s] -- Data-Dir: /usr/share/libyui
[ 28s] -- Theme-Dir: /usr/share/libyui/theme
[ 28s] --
[ 28s] -- Disable shared library: OFF
[ 28s] -- Include Debug-Symbols in library: OFF
[ 28s] -- Build a static library, too: OFF
[ 28s] -- Build the examples, too: ON
[ 28s] -- Build the tests, too: ON
[ 28s] -- Generate test code coverage: OFF
[ 28s] --
[ 28s] --
********************************************************************************
[ 28s] --
[ 28s] -- Configuring done
[ 28s] -- Generating done
[ 28s] -- Build files have been written to:
/home/abuild/rpmbuild/BUILD/libyui-ncurses-pkg-2.49.0/build
[ 28s] + make -j2
[ 29s] Scanning dependencies of target yui-ncurses-pkg
[ 29s] [ 3%] Building CXX object
src/CMakeFiles/yui-ncurses-pkg.dir/NCPackageSelector.cc.o
[ 29s] [ 6%] Building CXX object
src/CMakeFiles/yui-ncurses-pkg.dir/NCPackageSelectorPluginImpl.cc.o
[ 34s] [ 10%] Building CXX object
src/CMakeFiles/yui-ncurses-pkg.dir/NCPackageSelectorStart.cc.o
[ 36s]
/home/abuild/rpmbuild/BUILD/libyui-ncurses-pkg-2.49.0/src/NCPackageSelector.cc:
In member function 'void NCPackageSelector::createYouLayout(YWidget*)':
[ 36s]
/home/abuild/rpmbuild/BUILD/libyui-ncurses-pkg-2.49.0/src/NCPackageSelector.cc:1702:62:
error: invalid new-expression of abstract class type 'NCPushButton'
[ 36s] cancelButton = new NCPushButton( hSplit5, _( "&Cancel" ) );
[ 36s] ^
[ 36s] In file included from /usr/include/yui/ncurses/NCDialog.h:32,
[ 36s] from /usr/include/yui/ncurses/NCWidgetFactory.h:37,
[ 36s] from
/home/abuild/rpmbuild/BUILD/libyui-ncurses-pkg-2.49.0/src/NCPackageSelector.cc:42:
[ 36s] /usr/include/yui/ncurses/NCPushButton.h:34:7: note: because the
following virtual functions are pure within 'NCPushButton':
[ 36s] class NCPushButton : public YPushButton, public NCWidget
[ 36s] ^~~~~~~~~~~~
[ 36s] In file included from /usr/include/yui/YButtonBox.h:31,
[ 36s] from /usr/include/yui/ncurses/NCButtonBox.h:30,
[ 36s] from /usr/include/yui/ncurses/NCWidgetFactory.h:33,
[ 36s] from
/home/abuild/rpmbuild/BUILD/libyui-ncurses-pkg-2.49.0/src/NCPackageSelector.cc:42:
[ 36s] /usr/include/yui/YPushButton.h:224:18: note: 'virtual void
YPushButton::activate()'
[ 36s] virtual void activate() = 0;
[ 36s] ^~~~~~~~
[ 36s]
/home/abuild/rpmbuild/BUILD/libyui-ncurses-pkg-2.49.0/src/NCPackageSelector.cc:1707:58:
error: invalid new-expression of abstract class type 'NCPushButton'
[ 36s] okButton = new NCPushButton( hSplit5, _( "&Accept" ) );
[ 36s] ^
[ 36s]
/home/abuild/rpmbuild/BUILD/libyui-ncurses-pkg-2.49.0/src/NCPackageSelector.cc:
In member function 'void NCPackageSelector::createPkgLayout(YWidget*,
NCPkgTable::NCPkgTableType)':
[ 36s]
/home/abuild/rpmbuild/BUILD/libyui-ncurses-pkg-2.49.0/src/NCPackageSelector.cc:1821:61:
error: invalid new-expression of abstract class type 'NCPushButton'
[ 36s] cancelButton = new NCPushButton( hSplit, _( "&Cancel" ) );
[ 36s] ^
[ 36s]
/home/abuild/rpmbuild/BUILD/libyui-ncurses-pkg-2.49.0/src/NCPackageSelector.cc:1826:57:
error: invalid new-expression of abstract class type 'NCPushButton'
[ 36s] okButton = new NCPushButton( hSplit, _( "&Accept" ) );
[ 36s] ^
[ 37s] make[2]: *** [src/CMakeFiles/yui-ncurses-pkg.dir/build.make:63:
src/CMakeFiles/yui-ncurses-pkg.dir/NCPackageSelector.cc.o] Error 1
[ 37s] make[2]: *** Waiting for unfinished jobs....
[ 38s] make[1]: *** [CMakeFiles/Makefile2:187:
src/CMakeFiles/yui-ncurses-pkg.dir/all] Error 2
[ 38s] make: *** [Makefile:163: all] Error 2
[ 38s] error: Bad exit status from /var/tmp/rpm-tmp.phYzj1 (%build)
[ 38s]
[ 38s]
[ 38s] RPM build errors:
[ 38s] Bad exit status from /var/tmp/rpm-tmp.phYzj1 (%build)
[ 38s]
[ 38s] yast-jenkins failed "build libyui-ncurses-pkg.spec" at Wed Apr 17
16:37:19 UTC 2019.
[ 38s]

The buildroot was: /var/tmp/build-root/openSUSE_Factory-x86_64
rm -rf devel:libraries:libyui
rake aborted!
Command failed with status (1): [yes | osc -A 'https://api.opensuse.org/' b...]

Tasks: TOP => osc:sr => osc:commit => osc:build
(See full trace by running task with --trace)
cleaning
Build step 'Execute shell' marked build as failure
Not sending mail to unregistered user lslezak@xxxxxxx

< Previous Next >
This Thread
Follow Ups
References