Martin Schmidkunz write:
Thanks for all your comments!
Concerning hide/show behaviour:
There is already a basic overview concept created by Robert Lihm (gagarin.suse.de):
On hover the basic actions (edit/delete) are shown and then executed on click.
I didn`t use this mock up because it was too complex for my skills (e.g. it used three
different style sheets)
I will add it to the style guide in the next days.
after experiencing Robert`s mock up, what are your impressions now?
Robert mock is better. Why? Because mouse over just show actions. Problem of your mock is
that after mouse over page start changing, moving etc. And it is stressing ( because it
looks like "action" ) because you just move mouse over.
So I think that in general mouse over is good for hide/show which doesn't move
anything on screen. If you need to show more details etc I prefer click to show and click
Concerning the term "repository":
OK, let`s stick with it (although my stomach aches a little bit, but at least we are
consistent with other Novell products and avoid another major time consuming discussion)
An icon would be one solution, but it would break with the rest of the current webYaST
The other idea would be to add a simple line of text like "If packages are available
in more repositories, the one with the highest priority will be preferred." in a
smaller font below the term "Priority".
Spinbox would be a good idea nonetheless I suggest to give the user a hint about min/max
values and meaning of values (0 highest, 99 lowest)
Maybe so big range is confusing for target customer...maybe we should reduce options to
small subset like always preferred (0), prefered (25), default (50), use when better is
not present (75), latest chance (99). And I think we should use names for states, because
number doesn't say behavior of that number. If you have priority and names for
priority states you can easy understand. Numbers is good when you want exact data and it
is important like age or date of birth. I think target user need maximum five states (but
I think that 3 should be also enough). And if you still want to use numbers I prefer
slider over spinbox especially if we have range.
Enable/disable: Why not use a check box?
The reason is that check box has a relative small target hit area compared to a button.
Secondly combined with explanatory status text a labelled button seem to be more easy to
"Keep downloaded packages"
Is this really something for the GUI? Compared with the settings level in other module
this seems quite complex to me.
agree. And if we still want to use it I think better name is one which say why user should
enable this checkbox like "Save bandwitch for reinstalling from this repo"
maintainer of perl-Bootloader, YaST2-Repair, parts of webyast
To unsubscribe, e-mail: yast-devel+unsubscribe(a)opensuse.org
For additional commands, e-mail: yast-devel+help(a)opensuse.org