On 2/17/21 3:13 PM, Patrick Shanahan wrote:
* Michael Spartana <furryllama@comcast.net> [02-17-21 13:34]:

            I believe there is a problem with the latest tumbleweed version
of hplip (hplip-3.20.11-1.4.x86_64 )

        I am unable to install the plugin and am getting the error:

        Error importing HPLIP modules.  Is HPLIP installed?

        I checked on google and this type of error has been seen before. 
Probably no one else has seen it

        on tumbleweed as most tumbleweed users probably don't keep
reinstalling the OS.

        I'm not on factory so could someone look into this.....Thanks,
I installed hplip-3.20.11-1.4.x86_64 using zypper but no additional
"module" was requested or suggested.  in what manner did you receive this
request or how did you install hplip?

ps: do not use hp's offering, but use the package from the Tumbleweed

    Yes Patrick I used the opensuse version as I had to reinstall tumbleweed.

    I tried hp-setup which said it was installed successfully, then got:

The device you are trying to setup requires a binary plug-in. Some functionalities may not work as expected without plug-ins.

Please run 'hp-plugin' as normal user to install plug-ins.

and the setup stopped. I then used hp-plugin and that said the plugin was installed. So then I tried the hp program

and that's when I got the "is hplip installed" ?

So I'm kind of stumped. The printed was working fine with previous tumbleweed.