Dear Community,

I'm running OpenSUSE Tumbleweed and I have added the repository for Cuda from the Nvidia Website. I also added the "official" nvidia-repository for OpenSUSE, which however is for Leap, not for Tumbleweed.

I installed Cuda, which pulled the nvidia-drivers "nvidia-computeG05", "nvidia-gfxG05-kmp-default" and "nvidia-glG05" of the 530 family. Everything was working fine. I recently did a zypper dup. After rebooting, the window manager doesn't start and I'm sent to a console login.

The X log tells me, among other things:

[    65.945] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[    65.945] (EE) NVIDIA:     system's kernel log for additional error messages and
[    65.945] (EE) NVIDIA:     consult the NVIDIA README for details.
[    65.945] (EE) No devices detected.
[    65.945] (EE)
Fatal server error:
[    65.945] (EE) no screens found(EE)
[    65.945] (EE)

dmesg and journalctl have no trace of anything related to nvidia.

I tried to look for why the nvidia-driver (graphics card Nvidia GTX 750 Ti) doesn't load, I found that there is no "nvidia*.ko" in the directory /lib/modules/6.3.1-1-default/updates/. I tried to reinstall the drivers in order to see if it would recompile the kernel module against the new kernel, but I got the first error message (please let me know if attaching text files to this list is not appropriate and if you would like it pasted online somewhere instead).

I thought that may be because the cuda-repository for Leap is no longer at the same kernel version as Tumbleweed and disabled it. Trying to reinstall the above mentioned nvidia-drivers found only the family 470 and offered me, among other options, to downgrade "x11-video-nvidiaG05-530.30.02-0.x86_64" to "x11-video-nvidiaG05-470.182.03-53.1.x86_64", which I accepted. During the recompilation of the kernel module I got the errors in Error2.txt, which are very similar to the errors I got the first time.

I'm out of clue as to what to try next and would appreciate any help.

Thank you