Am 08.07.2016 um 22:13 schrieb Christian Boltz:
Am Freitag, 8. Juli 2016, 08:33:27 CEST schrieb Johannes Weberhofer:
I have updated the mediawiki and now recognized,
that it installs also
on (now) unsupported PHP versions. It requires php >= 5.5.9.
PHP is currently provided by php5* and php7* packages. The problem I'm
facing is, that all current installations of openSUSE does not
provide it's version while providing php or mod_php. This is what php
provides (among some other):
php-api = 20121113
php5 = 5.5.14-50.1
Shall I use the php-api versions to decide when to install? Is there a
way to allow installation on "php5 >= 5.5.9 OR php7" ?
I'd try something like
Conflicts: php5 < 5.5.9
I'll try that, don't currently have a better idea...
Using php-api might be another workaround. Probably
easier on the
technical level, but harder to understand for the average user. I don't
worry about users querying rpm --requires mediawiki (because they are
probably above the "average" level), but you might trigger messages like
"mediawiki requires php-api > 20121113, but no package provides it" on
installation (attemps) - and such a message is not really helpful.
Unfortunately the php-api version is also not the right way: PHP_API_VERSION ist set to
20121113 for all PHP 5.5 versions...
I'd also recommend to do a SR to the php5 and
php7 packages - the "php"
provide should include the version number so that you don't need to use
hacks like the above in the future ;-)
Oh, and it looks like rpm 4.13 will introduce what you'd need:
(Tumbleweed has rpm 4.12)
BTW: Fedora allows using this new feature only in Suggests:, Enhances:
and Supplements: - but not in Requires: or Recommends:
Thanks for your support!
Weberhofer GmbH, Austria, Vienna
To unsubscribe, e-mail: opensuse-packaging+unsubscribe(a)opensuse.org
To contact the owner, e-mail: opensuse-packaging+owner(a)opensuse.org