Hi Togan, Quoting Togan Muftuoglu <toganm@opensuse.org>:
Following a mail to the opensuse-buildservice regarding lua packages development <http://lists.opensuse.org/opensuse-buildservice/2012-09/msg00144.html> I would like to propose the following packaging guidelines for Lua since the projct does not have one.
good initiative and, as such, needs to be supported...
1) The main development should be taking place in devel:languages:lua and therefore devel:languages:misc should be droped as the devel repo for Factory.
you could start this effort by populating the packages (preferably as links to openSUSE:Factory, where they are already pushed). Any package that made it into devel:languages:lua should get a changedevelrequest to have the official devel repo follow the new package.
2) various lua packages that are scattered around the OBS should be developed in devel:languages:lua
Agreed... this would be especially important to be followed by Factory Reviewers, who agree to having a package come from a specific place.
Guidelines for Lua packages
Macros are already defined by the lua and lua51 packages in devel:languages:misc
=> should probably read devel:languages:lua; and so it's not a lie, start with adding the packages there. Once the guideline is documented in the wiki, it would be good for it not to point to 'outdated' repositories.
# RPM macros for Lua
# The major.minor version of Lua %lua_version %(lua -e 'print(_VERSION)' | cut -d ' ' -f 2)
# compiled modules should go here %lua_archdir %{_libdir}/lua/%{lua_version}
# pure Lua modules should go here %lua_noarchdir %{_datadir}/lua/%{lua_version}
* Addon packages Lua add-on packages should generally follow the naming scheme of lua(version)-PKG_NAME -- e.g.
lua51-luafilesystem -- tobe used with lua version 5.1 lua-luafilesystem -- tobe used with lua version 5.2
This requires definition on when lua(version) vs lua is to be used. How will you handle a lua 5.3 release? Will it get the lua namespace, invalidating all exising 'lua-<pkg>' items, as they would no longer the naming convention? Or will lua 5.3 automatyically become lua53? If so, why the exception for lua 5.2?
* Development Packages Development packages should have devel suffix added to the package name lua(version)-PKG_NAME-devel Example
lua51-luafilesystem-devel
Makes sense. For the guideline (note, I know nothing about lua), it might be beneficial to give some examples of what 'devel' files could be... In C we all know about the files *.so, *.a, *.h...
* Documentation packages If a package has huge documentation or is just a doc package then naming should be lua(version)-PackageName-doc and should be installed to %_defaultdocdir
/usr/share/doc/packages/lua-{PKG_NAME}-doc/*
An advise on 'when a package is huge' can be good here... in any case, it's important to mark documentation as %doc (so rpm --excludedocs knows about it)
Many upstream Lua developers use LuaRocks to distribute their modules. Therefore we probably should be finding a way to integrate luarocks in our build system and possibly provide a packaging mechanism similar to py2pack of python
Best regards, Dominique / DimStar -- To unsubscribe, e-mail: opensuse-packaging+unsubscribe@opensuse.org To contact the owner, e-mail: opensuse-packaging+owner@opensuse.org