On Tue, Jan 23, 2018 at 10:57:24AM +0200, Dave Plater wrote:
On 23/01/2018 10:11, Richard Biener wrote:
gcc48 also supports this flag. I would suggest to change the packages requiring the non-system gcc5 to instead require gcc7.
I've done that with xine-lib and will do that with libmlt but audacity which has a gcc minimum of 4.9 has to build with the same version of gcc as wxWidgets-3_0-nostl which the 42.3 update package is built with gcc5. Packman doesn't seem to use the same optflags yet and I can disable and wipe binaries in multimedia:apps/audacity 42.3 but I suppose I'll have to rewrite optflags for 42.3 audacity. Roll on Leap:15. Why did this bite 42.3 and not 42.2?
I only enabled it on 42.3.
Note that 42.2 goes EOL this week.