Good morning ladies and gentlemen,
is there any documentation on how to exactly require a specific version of go1.X (use go1.10, not any later version? Use go1.12 or later?)?
I am (once again) new to packaging golang packages, and have some that seem to require newer versions, e.g. go1.12 or go.14. Others like git-lfs seem to not build correctly unless I tell them to build with go1.10. Not sure if this really fixes the build problems, and as I am not a go expert I cannot tell if this idea is complete bogus. Nevertheless, I'd like to try out... ;-)
This seems to work: BuildRequire: go < 1.13 BuildRequire: go >= 1.12
This does not: BuildRequire: go1.12
Nope: BuildRequire: go = 1.12 (as the available version is 1.12.9 or something like that)
Seems like this would be a useful information to add to https://en.opensuse.org/openSUSE:Packaging_Go (which I will update once I find out how to do that).
Kind Regards, Johannes