
On 24.8.2017 09:23, Sebastian wrote:
All Python module packages, whether pure Python or C-based, should be called python-modulename. modulename must be the name of the package in the package's setup.py, which is equal to the filename of the source
I would remove the "equal to tarball filename" part. There is no guarantee about that.
tarball. If this differs from the name on the Python Package Index, the official third-party software repository for the Python programming language, the packgage should provide this name too.
better: "package should also provide 'python-<pypi name>' Maybe also something about packages without setup.py? "When a package doesn't exist on PyPI and no setup.py is present, the <modulename> is left to the packager discretion. Upstream preferred name, tarball name or site-packages directory name are reasonable choices."
And does the Packaging guidelines change process apply here? https://en.opensuse.org/openSUSE:Packaging_guidelines_change_process IMO it does.
We are discussing the change right now, so that can be checked off :) Other than that, let's see. This is a clarification of ambiguity, and for 99 % of packages it does not represent a change. We *could* test this in rpmlint though. That would catch messed up packages that now definitely exist. We could get a pypi-checker that would also verify Requires against setup.py and requirements.txt (i hereby propose a rpmlint check, that's another point done ;) ) Seriously though, this would be nice, but requires some amount of work for which I definitely don't have the capacity right now. Putting it on the long-term TODO, contributions welcome. Even as a clarification, it's worth announcing, so we might want to let the Package Guidelines Team know. I don't think we need to bother with a RFC and a 14-day wait for this; in any case, we can start using the guideline even before "formally accepting", because, again, it's resolving an ambiguity. But of course feel free to send a RFC if you think it should be done. regards m.
Sebastian
On 08/22/2017 05:54 PM, Thomas Bechtold wrote:
On 21.08.2017 14:37, jan matejek wrote:
On 18.8.2017 16:41, Thomas Bechtold wrote:
There is a difference if we translate pip requirements (eg via metaextract[1]) to rpm requires (assuming that other pip packages use the correct name). The name we should use is then one that is written in the setup.py/setup.cfg file. Which is "gogs_client". So the correct name is imo python-gogs_client .
That makes sense and disambiguates the package name. How about this for a policy: Package should be named as python-<setup.py `name` field>. If this is different from PyPI name (e.g. gogs_client as setup.py name, gogs-client as pypi name), then python-<PyPI name> should also be provided.
Sounds good to me.
Tom