[opensuse-kernel] [PATCH openSUSE 42.3 09/19] power: axp288_charger: Replace deprecatd API of extcon