we recently added the latest version of cabal-install into the lts:7 project
, but the tool won't compile since it depends on Cabal >=1.24.1 && <1.25,
which we don't have since GHC 8.0.1 ships Cabal 220.127.116.11 as a core library.
Now, I see two options to remedy this issue:
1) We patch the GHC 8.0.1 build to contain the latest Cabal release or
2) we add Cabal-18.104.22.168 as an a additional library into the OBS project.
Option (1) is probably the easier solution of the two, but patching the GHC
build feels dangerous to me, because we'll venture into a territory that's
not supported by the GHC developers. Also, I am not aware of any other
distribution going that route.
Option (2) is perfectly safe, but it's hard'ish to pull off because we
cannot just add a second version of "Cabal" to our project (and certainly
not to Factory). So we'd probably have to call that library "Cabal_1_24_1_0"
and add appropriate "provides" and "conflicts" attributes. I'm not quite
sure how all this works since I haven't done such a thing before. Figuring
this out might be worthwhile, though, because in the long run we'll need
multiple versions of Haskell libraries available if we want to ship recent
versions of important tools. Right now, "stack" is blocked by version
conflicts, for instance, that we cannot resolve without having multiple
Anyhow, is anyone aware of a third option that I missed? Does anyone have an
opinion in this matter?
To unsubscribe, e-mail: opensuse-haskell+unsubscribe(a)opensuse.org
To contact the owner, e-mail: opensuse-haskell+owner(a)opensuse.org