I am just working on packaging changes of gstreamer for OpenSuSE 11.0.
The packaging scheme could be applied for the backports as well, because it should include all required provides/obsoletes.
Old names in Requires/BuildRequires could still be used, because new packages use split-provides, but using of new names is preferred.
OBS gstreamer-0.8 could follow the same conventions and then they can live together on one system.
Files inside will remain the same, but packaging will strictly follow library packaging conventions:
gstreamer-0_10: Only core modules. Requires new enough libgstreamer-0_10-0. gstreamer-0_10-utils: Contains versioned binaries. gstreamer-utils: Contains unversioned wrappers. Does not depend on any concrete gstreamer version, but requires gstreamer-utils_versioned virtual symbol. libgstreamer-0_10-0: Shared libraries. gstreamer-0_10-devel: Devel package. gstreamer-0_10-doc: Devel documentation.
Plugins packages will follow this naming scheme as well.
Please report any problems to me.