Am 31.03.21 um 07:48 schrieb L A Walsh:
On 2021/03/22 03:19, Hans-Peter Jansen wrote:
attempting to upgrade perl (5.32.0 -> 5.32.1) from the current TW snapshot 20210320
Problem: dh-autoreconf-19-1.1.noarch requires perl = 5.32.0, but this requirement cannot
Problem: perl-5.32.0-2.3.x86_64 requires perl-base = 5.32.0, but this requirement cannot
Problem: alien-8.88-4.10.x86_64 requires perl = 5.32.0, but this requirement cannot be
This is a perfect example of BAD requirements on specific versions of
Why does a 'noarch' package require a specific version of perl?
Also, according to the perl project, those requirements should
apply to perl-5.32. The binary API of 5.32.1 should be compatible
That's why perl-5.32.1 provides
perl(:MODULE_COMPAT_5.32.0) and perl(:MODULE_COMPAT_5.32.1)
And that's what the perl macros require - but unfortunately rpmlint for years
insisted on a perl require, so people opted for an explicit require.
I now fixed dh-autoreconf and still I get this from rpmlint:
dh-autoreconf.noarch: W: no-dependency-on perl-base 5.32.1
Lighten up, just enjoy life, smile more, laugh more, and
don't get so worked up about things.