Am 21.05.21 um 13:02 schrieb Juan Erbes:
El vie, 21 may 2021 a las 5:40, Michael Hamilton (<michael(a)actrix.gen.nz
The spyder python IDE fails to start because it requires a version of
TW 20210519 jumped python-38-watchdog from 1.0.2 to 2.1.1.
I've raised a bug:
Thanks for reporting. I hadn't noticed yet.
Can't the problem be solved by symlinks with the
required library names?
(pointing to the real name of version 2.1.1)
Python packages are not libraries, which you could "symlink". The
problem is that the egg-info for watchdog (correctly) says that it is at
"Version: 2.1.1", but spyder says in it's egg-info/requires.txt and a
couple of more places that it needs <2.0.0. The Spyder devs really like
their pinning, whether it is necessary or not [1, 2, 3]. And they are
really adamant about enforcing it. So thanks for keeping this on distro
level and not annoying them by openSUSE quirks.
Even worse, I missed that sypder 5.0.3 also requires spyder-kernels >=
Fixed in sr#894844